Ftp Connection failed (operation timed out)

EC2 Ubuntu 16.04.7 LTS

Steps:

  • (Edit Users) Add a website FTP access user
  • Create a user with pass
  • Try to connect to server with cyberduck (FTP SSL)
  • Authenticates and spins on “Listing directory”

Eventually: Connection failed. Operation timed out. The connection attempt was rejected.

proftpd.log shows:

FTP session opened
USER myuser@domain: Login successful.
FTP session closed

Root user works as desired but I’d rather not use that much less spread those credentials around.

Check the ProFTPd logs for clues. Make sure you’re using the correct username (from Mail and FTP Users page).

I would try the sftp protocol not the ftp-ssl or ftps with cyberduck.

16.04 was end of life last month. It is no longer supported. You really need to upgrade.

I also had issues with FTP once. I don’t typically use it. I just started switching the protocols until one worked as @stuckinthehouse suggests. I think I wound up just using the regular FTP selection and it worked.

1 Like