French Language problems in Usermin

I am migrating mail from an old system to Usermin and I have 2 main problems regarding the language.

I’ve installed RoundCube and it is working almost perfectly, but it does not offer options to reset the password or manage mail filters so my users have a need to fall back to the Usermin UI occasionally.

  1. I need each individual user to be able to choose their preferred language - This is possible in RoundCube but the default UI for Usermin does not seem to allow users to choose their own language. I can set the language globally but that is not what I need. Some users require French and some require English.

  2. Mail folders have very odd names in the Usermin UI. For instance, the folder that is called “Éléments enveyés” in RoundCube, shows up as “&AMk-l&AOk-ments envoy&AOk-s” in Usermin. I see no way to fix this.

  1. Webmin->Usermin Configuration->Available Modules->Check “Change Language”
  2. Choose a Unicode encoding language, e.g. FR-UTF8. I’m pretty sure Authentic has issues with non-UTF8 encodings.

Hey Joe thanks for the info.

  1. works great, thanks.
  2. this seems to have no impact at all on the folders in the mail UI. I tried it previously.

Hmm…I dunno. Maybe @Ilia knows.

I’m actually considering abandoning the Read Mail in Usermin and just force everyone to use RoundCube. It’s a bit annoying as they need to revert to Usermin for some forwarding/settings, but it may be the simplest solution. But if you do know of a solution that would be handy.

I have just created a folder you mentioned and it just displayed as expected, in both FR and FR.UTF-8. The only issue I noticed that Inbox is printed as Messages reçus but this is the way it’s defined on the language file (shouldn’t be nowadays).

Sorry to hear that. Is this because of encoding issue? However, I understand that mail listing is not ready yet, along with few other features (address book integration, better folder management and etc), and besides, there are still, small issues spoiling UX, that has to be fixed. I am aware of them, and it’s on my to-do - it’s just very-very time consuming to make such things to be super awesome (this is will happen though and it’s my goal).

Please share more of your negative experience. I will advice and try to help out. I think, something could probably be fixed right now (like wrong options) and something, like mentioned above, will take more time.

@Ilia thanks for the help.

When I try to create a folder named Éléments enveyés via folder management in Usermin I get this error message " Folder names can only contain letters, numbers, spaces and the characters dot, dash and underscore" So there is some underlying issue on my system.

Oddly RoundCube seems to be working fine, but I would like to get to the bottom of this. Is there some OS level setting that I need to change?

[/quote]

This is probably the old limitation and we could safely remove it nowadays, right @JamieCameron?

The restriction to creating folders is certainly a problem and something I think needs addressing. But there is still an underlying problem with encoding. A folder that I named “Tésór fóldér” and created with no problems in RoundCube, shows up in Usermin as “T&AOk-s&APM-r f&APM-ld&AOk-r”

Screen Shot 2020-01-24 at 8.16.18 am
So there is something deeper going on here.

I note that Dovecot(IMAP) stores UTF-8 folder names on the file system in mutf7 (modified version of UTF7) and translates them back when reading the folders. But this is not happening correctly in Usermin. It’s almost as if Usermin is reading the folder names directly from the file system rather than via the IMAP API.

I’m not very familiar with all of this so it could also be that I’ve just set something up incorrectly.

Usermin supports either direct Maildir or acting as an IMAP client. I don’t remember what the default is, but I thought it was IMAP. We should try to make it work either way, but Unicode is hard (and this is the first I’m hearing of mutf7, so that’s even more complexity!). :wink:

But, check your Usermin configuration to see if it’s using Maildir directly or if it’s logging in over IMAP to retrieve mail and folders.

Joe where would that config option be? I’ve not found it.

Yeah I only found out about mutf7 while figuring this out. But it does imply that it is dangerous to access the file system directly and you should always do so via IMAP.

OK I found the setting and it was set to IMAP client so this is not helping me. But I was able to solve the problem with a bit of an annoying work around.

  1. convert all the folder names on the file system from mUTF-7 to UTF-8 via a doveadm script.
  2. set Dovecot to support UTF-8 by adding :UTF-8 flag to mail_location
  3. switch Usermin to use the Maildir directly. (oddly, even after stop 1 & 2, Usermin still gets the wrong format from IMAP).

So I think I have a solution but it seems odd to me that Usermin is getting the wrong encoding from IMAP.

So, IMAP is better in the general case, for a few reasons, but it’s usually minor. But, that does help narrow down what’s going wrong, and provides a path for reproducing the problem (and maybe fixing it). It’s not an area I’m gonna be able to be useful in anytime in the near future, but @Ilia and Jamie are in the midst of overhauling Usermin Mail, so it’s plausible they’ll be able to try to figure it out.

@Joe I think that should be default, setting it in UTF-8 - to do so, you need to edit 10-mail.conf files, and directive we currently set upon install is:

mail_location = maildir:~/Maildir

…while it should be:

mail_location = maildir:~/Maildir:UTF-8

I think I have a solution but it seems odd to me that Usermin is getting the wrong encoding from IMAP.

I could also reproduce it. Even though, using the same account, the folder containing special chars is created in Thunderbird with no problem, creating the same folder (using IMAP) is not working in Usermin and returns an error (Folder names can only contain letters, numbers, spaces and the characters dot, dash and underscore). It’s also not being displayed correctly, even though Dovecot itself displays it right:

image

However, it seems that Usermin is converting it back to something else while using IMAP (not Mailbox):

I will ask @JamieCameron to have look or I will, after theme 19.46 is released for 1.942/1.792.

Exactly - that is what I’m experiencing. If you look closely at the encoding you will see that the mUTF-7 folders on the file system are being double encoded when they render in Usermin and the UTF-8 folders are being rendered in mUTF-7. So it looks to me like Usermin is doing a UTF-8>mUTF-7 encoding when it reads/renders the folders - very odd. It should simply let Dovecot do it’s job and leave the output unchanged.

Regarding the default setting for encoding. If all is working well then it is somewhat irrelevant what encoding is on the file system, but UTF-8 is much easier to read and would surely be supported by most current file systems.

I think the issue is that the folder names being returned via the IMAP protocol command are encoded per https://tools.ietf.org/html/rfc6855 , which Usermin doesn’t support yet.

Don’t !!! Don’t create a folder “Eléments envoyés” ! As a world standart, the folder for sent emails remains always the “sent”, splelled “sent” folder. Then emails platforms and softwares such as Thunderbird translate these special folders (INBOX, sent, trash, spam, Drafts, …) to the local language folder names. Except these of course, is uses the proper name for custom folders.
The topic remains interesting about any other custom folders. I just checked, Postfix does not store them in UTF 8 but does a strange thing. It stores them into filenames converted to (not sure what) so “Amélie” is in fact stored “Am&AOk-lie”.
image image
If you realy need to play with settings, as an experience, if the question concerns only european languages (no asian, hebrew, arabic, persian…), it’s much more smooth to try to change settings to ISO-8859-15.
The “15” version of ISO-8859-1 includes all accents of european languages and is much more troubleshouting than the conversion to UTF8.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.