FreeBSD 13 - PHP script execution mode is Disabled

OS type and version FreeBSD13.2
Virtualmin version v7.2


We are a long time user of Webmin under FreeBSD and are now trying to implement Virtualmin but have been unable to resolve why the PHP script execution mode is Disabled.

Using FreeBSD v13.2 with Virtualmin v7.2.
PHP 8.2.7 is installed (and confirmed with php -v).
Running PHP-FPM (confirmed via info.php showing Server API = FPM/FastCGI and PHP-FPM=active)

Apache config includes:
LoadModule mpm_event_module libexec/apache24/
LoadModule proxy_module libexec/apache24/
LoadModule proxy_fcgi_module libexec/apache24/

<FilesMatch “.(php|phtml|inc)$”>
SetHandler proxy:unix:/tmp/php-fpm.sock|fcgi://localhost/
(Closing FilesMatch)

php-fpm.conf includes:
listen = /tmp/php-fpm.sock

When running System-Settings - Recheck Configuration: get the following relevant responses:
Apache is installed
Apache supports HTTP/2 on your system
No PHP execution modes are available!
No PHP-FPM packages were found
Apache is configured to host SSL websites

When going to Server Templates - Default Settings - PHP Options: shows the following:
Default PHP Execution Mode = Disabled
Default PHP Version = 8.2.7

I have tried two separate FreeBSD installs on different servers and I am getting the same results. I have searched for the answer and tried lots of tweeks but I just cant get it change the Default PHP Execution Mode from Disabled to PHP-FPM.

Everything else in Virtualmin is working well.

Any advice or guidance is appreciated.

I’m having the same problem. Have you found a solution yet?

freebsd is a grade B OS, which means that its not fully suported and you’ll need to be more experienced in virtualmin to fix bugs and make it work, they cleary say in the docs to not bother asking questions for theses OS, so i dont know if you’ll get any answers.

We don’t mind folks asking questions about using Virtualmin on such systems. It’s the installation that we’re discouraging questions (because if someone can’t even install all the components, they absolutely should be using a well-supported distro with installer support and us answering questions about basic stuff like how to install and configure Apache for virtual hosting is just leading them further down a bad path). I don’t think that applies here.

In this case, I’m pretty sure there’s an issue in the Virtualmin github about this specific problem, and it just comes down to Virtualmin doesn’t know where to find php-fpm on FreeBSD, because it doesn’t put it in any of the places any Linux distro does.


Thanks Joe.

Have not been able to solve the issue so now looking at switching to Debian.

Not the only one having this issue as you have pointed out and hopefully will be resolved in time.

As always, if you want an easy experience, a Grade A supported OS is the right way to get it.

We’re a tiny team with other jobs, it’s impossible to stay on top of even the handful of grade A Linux distros…adding a bunch of other operating systems into the mix is a lot. We try, but mostly we need for folks who really must use other distros/OSes to contribute patches to deal with things like path differences and such. It’s usually in a config file somewhere rather than needing code (though this one isn’t, I don’t think).

Edit: Also, you’re missing a lot of other stuff on FreeBSD, if you haven’t put in a .lot of time configuring and a little bit on building. The install process does hundreds of steps. Doing all that manually would take a few hours, if you know what you’re doing and may be impossible if you don’t. I really try to discourage folks from using non-Grade A distros because it makes Virtualmin look hard to use and like it’s missing a bunch of features.