FQDN not set correctly during install?

Hi, I do have a problem with the FQDN possibly not set correctly in Virtualmin. I’m using Virtualmin 3.62 on Ubuntu 8.04. When creating new virtuell servers the owner of the new server should be informed by Email. That Emails never arrived yet so I checked /var/log/mail.log and did notice the From address used looks like this: <webmin@host> whereas it must look like this <webmin@host.domain.tld> (FQDN).

Checking the Virtualmin install log it looks like set correctly:
Hostname OK: fully qualified as host.domain.tld

I know it is possible to configure the From address in System Settings > Module configuration.

I wonder though if the missing FQDN in the default From address may be a sign of some misconfiguration and may lead to further problems elsewhere. Any thoughts?


Two things:

Try restarting Postfix, and see if things look better.

Did you add any other configuration to Postfix outside of the install? Like setting myorigin, perhaps?

Hi Bernhard – in addition to what Joe asked, I’d also be curious what the contents of /etc/hostname are.

Thanks for answering!
Here is some more information:

Settings from /etc/postfix/main.cf:

  • mydestination = smtp, smtp.domain.tld, mx, mx.domain.tld, host, host.domain.tld, localhost.domain.tld, localhost
  • myhostname = mx.domain.tld
  • myorigin is commented out (its default is to use myhostname)

Postfix was restartet several times, no change.

hostname -f prints: host.domain.tld

Using the mail command from command line to send mail it is correctly formed:

In /etc/hosts I have set some CNAMEs of host.domain.tld added - just in case (and may be not necessary): localhost
xxx.xxx.xxx.162 host.domain.tld host
xxx.xxx.xxx.162 smtp.domain.tld smtp
xxx.xxx.xxx.162 mx.domain.tld mx
xxx.xxx.xxx.162 pop.domain.tld pop
xxx.xxx.xxx.162 imap.domain.tld imap