I setup a new virtual server this morning, all default settings.
I can view the site fine through webmin as the proxy, but when I try to get the site direct through the domain name, I get:

You don’t have permission to access / on this server.

What is wrong with this setup? FTP is fine, email seems fine, just can’t get the site. Again, I used the default setup when creating this virtual.


Which version of Virtualmin are you using? If you are using an old version, there may be a bug.

You can fix the problem with:

chmod 750 /home/domainname

Read here

chmod did not fix it.
I’m running 3.41

the other strange thing I notice is if I explicitly access the index.php file which does exist I get a 404.

Hey Greg,

What’s in the error_log (both /var/log/httpd/error_log or /var/log/apache2/error_log and /home/domain/logs/error_log) when you hit the page? That might give us a clue.

For PHP stuff, I’d suspect maybe the wrong Apache version got installed. Ours has suexec rebuilt for the docroot in /home, while the default on most operating systems is somewhere in /var.

Oh, I didn’t mention how to check the apache:

As root, execute:

suexec -V

Then look for “-D AP_DOC_ROOT=”. If it’s /home, you’re good. If not, we’ll have to get the right Apache version installed.

Joe, it’s showing /home, so I guess we’re good on that end.
I think when you installed virtualmin for me you had to reinstall apache.

The logs are not showing anything that I can find. Shoot me an email at carbon8. I can’t figure out where this is failing. ;(

Ok, to follow up on this one now that it’s been resolved.

Apache was being configured with a private IP address found on eth0. The public IPs on the server were on eth1. Switching that in the Module Configuration:Other Server Settings page, and then using the Change IP Address form to fix it in all of the various configuration files knocked the problem right out.

Thanks for the help Joe!

Hello I am having a simualar issue though only when viewing the web page through Virtualmin (it works outside of virtualmin) I did discover that if I run suexec2 -V it returns -D AP_DOC_ROOT="/var/www" I am running on Ubuntu 6.06 and tried to reinstall appache via aptitude with the same results. What am I missing?

I’m having the same issue. It happened after my server froze for no reason. Now all my domains are throwing a 403 Forbidden error.