Follow-up on having nginx running after a reboot

OS type and version Ubuntu 22.04.4
Webmin version 2.111
Virtualmin version 7.10.0

If we have an up-to-date install of Virtualmin, do we need to do anything to have nginx run on reboot?

I did this, but nginx still doesn’t automatically start after a reboot.


Does it help if you increase the OnActiveSec value to, let’s say, 20 seconds?

All this assumes that Nginx is configured properly and manually running systemctl restart nginx works just fine.

systemctl restart nginx works fine, but replacing OnActiveSec=10 with OnActiveSec=20 in the file still doesn’t start nginx on boot.


After running sudo systemctl enable nginx.timer, it seems to work and nginx starts on boot. :+1:

That’s something we already do by default.