Fix the Graphical Console pls

I’m trying to post this as calmly as I can be… So, I have a nightmare for a few weeks with trying a different setup, Cloudmin involved. Big mistake as now I’m quite sure it isn’t mature at all and I have been really waiting for a run for quite a while; it’s no good, not for me, nor to the point of offering this to my clients.

The biggest prob. is the Graphical Console - it never fits any “screen”, it can be run only in 800x600px cause any other resolution the task bar is… hidden and u can’t switch anything, the mouse is the worst ever, there is no clear way of capturing the mouse and the keyboard (and does the clipboard work?) it always exits from the console and… i get to search something in the browser

…and now…

Why the hell is erasing everything when i press shift??? And you can’t stop the damn thing is like you are pressing delete continuously. So… as root it deleted the entire /etc directory, anyone knows isn’t usefull/good at all right? Restored the damn thing, restarted the machines, then what? When I was in the /etc dir trying to select files it deleted a part of them again! And just now deleted again /etc twice, when trying to sort it out.So thanks to Cloudmin I have a files/permissions nightmare on my hands.

You realise that it was all working and today at midnight I scheduled the first backup of the vm??? And I lost - or at least i don’t trust, what i was doing for weeks? Thanks for starting over dudes!

Well you might say, I have some fancy G19 keyb and a RAT mouse - no I don’t, I have the Elite Desktop set from Microsoft, one of the most compatible things ever created by them. For like 8 years…

This is unprofessional to the point of dangerous to let loose something like that in an enterprise grade product. And why do you think you can give something like this to a customer, ours or yours?

GJ guys never thought you’ll stumble in a mouse and a keyboard…

Later edit: anything that is pressed longer triggers the behaviour.

Could you tell us what browser you are using to access Cloudmin, and on which operating system?

Also, which OS are you running inside the VM?

I haven’t seen problems like you describe with the graphical console. Although for Linux VMs, it is usually easier to just SSH in - the graphical console is useful mainly when the VM cannot be accessed over the network.

Freshly installed:

Operating system CentOS Linux 6.3
Webmin version 1.590 Virtualmin version 3.93.gpl GPL
Cloudmin version 6.4.kvm Theme version 8.5
Kernel and CPU Linux 2.6.32-279.2.1.el6.x86_64 on x86_64

Operating system CentOS Linux 6.3
Webmin version 1.590 Virtualmin version 3.93 Pro
Theme version 8.5
Kernel and CPU Linux 2.6.32-279.5.1.el6.x86_64 on x86_64

Using Firefox 14.0.1 on Windows 7 x64. I understand, but you can’t expect always and everyone to use only the console… As an observation everything in the console is flimsy, awkward and buggy somehow - of course I don’t expect a near-desktop-full-experience but hey - we should be able to type and point and click things.

Pls don’t leave this like the file manager in webmin (priceless for me at least) for years without an update. Hope I’m wrong, but it has exactly the same speed, functionality, looks and shortages for a long time. And both of them no scroll…

To fix the resolution issue, try going to Edit System -> Advanced KVM details and changing “Enable high resolution graphics?” to “Yes”, saving, then rebooting the VM.

I assume you are running some kind of desktop environment on the VM console, rather than just using the text login?

But it is set to yes. Using Gnome.

One question: how does the restoring work in webmin, cloud and virtualmin? Do the scripts open the files, write in and save, or rather overwrite. Specially the webmin backup feature - I’m interested if it retains the rights of the original new machine, cause I would like to use whatever I can get to shorten the time of deployment.

One thing you could try is connecting to the graphical console using another VNC client application, using the hostname and port that is displayed at the bottom of the Graphical Console page. That would reveal if the problem is due to Cloudmin’s VNC client (which we can maybe fix), or some interaction between Gnome and KVM (which we can’t).

No problem with TightVNC, wich is what i will use for now on. Any word on the backups question?

It’s true the graphical console is horrible.
After I log in and do a simple update, it will ask for my password again so i never get anywhere.
Also often the text in the console after the attempt of logging in is sort of scrambled
Using realvnc client, I cant even reach the VM with the address mentioned in Cloudmin.

Firefox 13.0.1, Host and VM is Centos 5.8

I never use the Console but I wanted to support the complaint.

Currently the console uses a Java VNC client applet which is really old, but has the benefit of being freely available. However, we are looking into using an HTML5 / Javascript VNC client instead, assuming it can be done with reasonable latency. That should fix some of these issues …

Regarding backups, they are quite different across the various Webmin / Virtualmin / Cloudmin products. Can you explain a bit more about what you are trying to do?

Thank you for listening to your users and doing something about this problem.

For the backups part, it was strange at first 'cause Webmin didn’t want to restore anything, complaining about the pid file; restarted the service and worked. I already erased the old VM and started from scratch but first I made a backup with Webmin - tried to save the most important server related files in /etc and restore them onto the new VM.

This was my question when you backup with Webmin>Backup Configuration Files how is the restore done: overwriting the file or it just writes in and saves it? And the permissions are preserved (yes they are I think)?

The Backup Configuration Files module just creates and extracts tar files of files associated with the various Webmin modules, such as the Apache or BIND configurations. This means that the permissions that were set at the time the backup was taken will be restored …

I whole heartedly agree yngens, It is the most stable and user friendly Hosting Panel I have ever seen. I also have run into to little things but that is true with any software. I am a Linux System Infrastructure Admin. and this is true with anything that is out there.

Hands down in my eyes, Virtualmin, Webmin, Cloudmin have them all beat…

KUDOS to the team here, AWESOME WORK! and thank you for your efforts…


Dear yngens and the nexus guy, if there is a blame here I think someone should asume it, though I’m not asking for it. I’m asking for a fix - and It passed a few months without a resolve. Well, clicking in the web interface, and just deleting a whole (config) directory by itself doesn’t qualify as a glitch, but as a huge problem. And as stated in the name of the thread was not about a blame, but about a fix.

And no - the open source software shouldn’t be buggy becasuse it’s open, and no it’s not on my part as you gratiously are inclined to think - pls don’t mislead people! This thread (and issue) is still open.

It took months before I used one of my domains for “serious” testing, after the “testing”, and a few other months before I added the second one, and everything while playing with the VMs, and a few whole reinstalls, and other new VMs… etc etc. And as stated, when thought it was cool - it wasn’t. In fact obtained a disaster. So pls don’t give advices on my… time?

Anyway, Happy Hollidays to all of you, the team, the community, the users!

Dear Fakemoth,

I really do simpatize with all what you had to go through. However at the same time I have to stand up for the creators of Webmin/Virtualmin/Cloudmin. The software might be less than perfect, however it fully satisfies needs of many webmasters, system administrators, hosting companies. You have to always throughly pre-test any software before you decide to use it for serious businesses and solid purposes, that part of the job is fully your responsibility before all possible risks.

I am pretty sure the fault had been somewhere on your part, since I remember very well when I tried my first Virtualmin I was quite confused and struggled through different unpleasant situations. However with more time working with it I, must admit, I have fallen in love with it. It is so much flexible, functional, feature-rich and, tell you what, stable, that you will see it will get more and more popular in hosting industry. The same praises go to Webmin, Cloudmin.

You just have to spend some more time with it and be little more attentive to details. The devil is always in details. I am sure I am not the only person who thinks so and believe many would confirm that Webmin is a generally very stable product together with its extensions - Virtualmin and Cloudmin.

All the best! And happy holidays to everyone, especially hardworking guys, who have created Webmin for all of us!