Firewalld error upon --reload

I’m running Virtualmiin on a Debian 10 system with firewalld active.

I issued the firewalld command to open port 8085:
firewall-cmd --permanent --zone=public --add-port=8085/tcp

But on firewall-cmd --reload, the error message displayed:
Error: COMMAND_FAILED: ‘/usr/sbin/ip6tables-restore -w -n’ failed: ip6tables-restore v1.8.2 (nf_tables):
line 4: RULE_REPLACE failed (No such file or directory): rule in chain INPUT
line 4: RULE_REPLACE failed (No such file or directory): rule in chain OUTPUT

I saw an old related post about getting a newer version of iptables (v1.8.2 was current) from the stretch-backports. I attempted to do so, but the apt update said that iptables was up-to-date (v1.8.2-4).

I tried using > Webmin > Networking > Firewalld but that also got a same/similar error.

I then tried to use the > Webmin > Networking > Linux Firewall to manually open port 8085 and it seemed to have added the new rule. But still no luck.

Now the Virtualmin Firewalld module no longer works (error Failed to list zones : Error: INVALID_ZONE) probably because I attempted “Directly firewall rules”

Anyone have any ideas for me to get past this firewall-cmd --reload error and get port 8085 open?

I do have the option to restore the vps to a previous backup without significant data loss. So I could reset to the original Firewalld config.

hi, I am thinking, when your issued that command did you save it as persistent rule? so later after reload the firewall would be able to read that rule and apply? - just asking…

I decided to not troubleshoot my firewalld problems and went the route of stopping and disabling firewalld and installing nftables.

I’m not sure if iptables is still active as I still can’t get port 8085 open.

I will close this topic (if I can figure out to close a post) and might post a new topic requesting help with my nftables/iptables transition.