Filezilla FTP SFTP won't connect

Ubuntu 12.04
Virtualmin 4.06 GPL installed via the script

Since install of the virtual servers I have not been able to use SFTP/FTP via Filezilla.

Status:	Connecting to thomasnoest.nl...
Response:	fzSftp started
Command:	open "thomas.thomasnoest@thomasnoest.nl" 22
Command:	Pass: **********
Error:	Authentication failed.
Error:	Critical error
Error:	Could not connect to server

Server Auth log:

Mar 21 17:40:11 s1 sshd[5750]: reverse mapping checking getaddrinfo for 84-245-52-153.dsl.cambrium.nl [84.245.52.153] failed - POSSIBLE BREAK-IN ATTEMPT!
Mar 21 17:40:11 s1 sshd[5750]: User thomas.thomasnoest not allowed because shell /dev/null is not executable
Mar 21 17:40:11 s1 sshd[5750]: input_userauth_request: invalid user thomas.thomasnoest [preauth]
Mar 21 17:40:11 s1 sshd[5750]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=84.245.52.153  user=thomas.thomasnoest
Mar 21 17:40:13 s1 sshd[5750]: Failed password for invalid user thomas.thomasnoest from 84.245.52.153 port 53220 ssh2
Mar 21 17:40:13 s1 sshd[5750]: fatal: Read from socket failed: Connection reset by peer [preauth]

Ass suggested by the documentation I then added the user to the SSH user list(changed the radio button away from the “all” option, restarted SSH; no avail. Restarted ProFTP; no avail. Server reboot; no avail.

Also tried plain FTP:

Status:	Resolving address of thomasnoest.nl
Status:	Connecting to 146.185.161.211:21...
Status:	Connection established, waiting for welcome message...
Response:	220 ProFTPD 1.3.4a Server (Debian) [::ffff:146.185.161.211]
Command:	USER thomas.thomasnoest
Response:	331 Password required for thomas.thomasnoest
Command:	PASS **********
Response:	530 Login incorrect.
Error:	Critical error
Error:	Could not connect to server

Server Auth log:

Mar 21 17:47:08 s1 proftpd: pam_unix(proftpd:session): session opened for user thomas.thomasnoest by (uid=0)
Mar 21 17:47:08 s1 proftpd: pam_unix(proftpd:session): session closed for user thomas.thomasnoest

That my ISP is a little off is not enough to upset the whole login proces, would it? Can anybody help me with this?

This is probably the key error:

Mar 21 17:40:11 s1 sshd[5750]: User thomas.thomasnoest not allowed because shell /dev/null is not executable

You need to assign a shell to the user (under “Other user permissions”) that allows FTP login, or SSH login if you wish to use SFTP.

That /dev/null line I was googling too.

Anyway, got it working with the main account name.

Whats SCP? ftp over ssh?

… has to be. It enabled SFTP

one warning for other users:

Setting the SSH permissions to a list of users (instead of the radio button to ‘all’) works for your whole machine! In my case it disabled my root account(list was empty and I only added the virtual server username). So I put the radio button back to ‘all’ and my root and sftp logins work.
So, these lines from the documentation seem to me outdated:

9 In Virtualmin -> Webmin -> Servers -> SSH Server
10 Access Control -> Only allow users -> add the above virtual server username

Right, that config option through Webmin/SSH Servers is not required for/related to allowing a Virtualmin user (S)FTP access.

SCP means “secure copy” and is “file copy over SSH”, so to speak a simplified version of SFTP which is “FTP-like file management over SSH”.