File to edit to remove pre-login warning / 2FA

While in Webmin I used the option pre-login I think is the term, and used /etc/issue file with a short warning blurb, but now I cannot get past the actual pre-login warning.
Here is the url:
Login Page
Even if I refresh page the page just keeps loading the issue file.

I cleared cache, tried multiple web browsers, same results.

I’m using 2fa also.

I cannot get to https://mysite.com:1000 but I can get to and login to https://mysite.com:2000

I’ve tried several ways of trying to check SSH files, issue file, and a few other blog articles.

Can someone try the login url and tell me if it is me and my pc, or still an issue with something on the server?
Also, maybe help me find the file that needs edited to dis-able this feature?

Strange one, this.

When I visit the URL for the first time, I see a red triangle stop sign / error sign. Then I visit the same URL in the same browser tab for the second time, I see usual webmin login screen.

This is missing:
https://smtp-jet.com:10000/images/favicons/webmin/manifest.json

In /etc/webmin/miniserv.conf, find:

twofactor_provider=totp and remove totp

And in /etc/webmin/miniserv.users, find something like:

root:x:0:::::::0:0:totp:HBL7W4ATG8T6FG8W:

Delete totp so the line reads:

root:x:0:::::::0:0::HBL7W4ATG8T6FG8W:

Restart Webmin: service webmin restart and login as usual - without 2FA.

Thank you, that worked, and I changed the setting to not use that option, re-enabled 2fa and it is working as expected and desired now. :star_struck:

I won’t select that option again! :upside_down_face:

1 Like