File Manager - Bookmarks List

SYSTEM INFORMATION
OS type and version Ubuntu Linux 22.04.4
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10
Package updates All installed packages are up to date

Nothing too serious, just a pointer required

the “bookmarks” list is a really nice feature and is filling up fast to the point of being unpleasant to use.

sure - they can be deleted but that is not really helpful when the list is long and in regular use and is still required.

So is there some method/setting/configuration to point to the location of the list?
or some way to sort entries in the list? (eg. by date added or perhaps their base location)

Thanks for the heads up! I will fix it in the next theme release.

It’s in ~/.filemin/.bookmarks file.

Thanks,

a little surprised that the number of items in there is short of the number listed by the “Bookmarks” button.

and perhaps even more that the owner:group is not the owner:group of the domain admin. I don’t know why but I did expect each domain admin (there is only 1 on this OS install) that has 4 slightly different domains (domain.xxx) to have their own list. (ie. under /hom/domain/.bookmarks or something similar)

If you’re logged in as root, the bookmarks file will be located in the /root/ directory.

yes got that!
but doesn’t explain why they are different?

I don’t understand what’s different and under which circumstances.

I tried to explain, The number of listed bookmarks in the “Bookmarks” Button is greater than those listed in the .bookmarks file! and I have tried adding - deleting and re adding a bookmark using the Button.

I still don’t get it. Could you please provide a screenshot of the bug?

sorry for the delay.

it took a bit of doing - still having some problems capturing images.

not quite sure if this helps much as I was tinkering all yesterday in an attempt sort this,

(bug is a bit extreme as it isn’t breaking anything) and really is more of an irritant by not understanding why it is happening.

the 2 images below were taken at the same time (me logged in as root) - no other user active on this system at the time.

I have added a few bookmarks (using the bookmark button)
bookmarks1

note the difference in the list given in /root/.filemin/.bookmarks missing items 8,9 (yesterday the lists were different the other way - more items in the button list than in the file) - I would have expected the lists to be identical
bookmarks2

if I change the order in the list (file) should that be reflected in the button list?

will the site owner (logged in as user not root) see those changes?

Maybe I’m missing something, but I clearly see that items 8 and 9 aren’t missing and are present in both screenshots. Can you name the items that are missing?

Yes, but you would need to re-enter the File Manager or refresh the entire page for the changes to take effect.

Bookmarks are user-specific, so if you’re logged in as root, the bookmarks are located in /root/.filemin/.bookmarks; therefore other users won’t see these changes.

oops - that is a must - just going back to the same page doesn’t rebuild the list on the button even if a new item in the button is selected. It requires a full page reload (Ctrl+r) or change of module.

so where are they located? for that user? not under /home/{user}

They are indeed located in /home/{user}/.filemin/.bookmarks file.

OK - logged in as the owner:group of this domain (the tool tip is now showing “Access Level: Server Owner”)

and was surprised to find my (root) bookmarks list under the “Bookmarks” button I was expecting the list of the server owner. the scarier thing is that I can see (potentially alter) everything up to / (though hopefully not)

Sorry, you’re mixing something up. Try adding different (distinguishable) directories and see if those are displayed among different users. I don’t see how it would be possible based on the current code. We always use remote user home directory. However, if a user doesn’t have a home directory then it may fall back to root’s home. Though this should never happen in the context of Virtualmin virtual server owner.

It is a little difficult - the owner is offline today so I cannot get them to login to see. as root I can and have created a new directory and a file - I’ll check back tomorrow - there is only one user (the Sever owner)

If you’re a master administrator, you can switch to that user by using the Switch To Server’s Admin link found in the Manage Virtual Servers sub-menu within the navigation menu.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.