FCGid causing server issues.

hello all -

i am running virtualmin on a virtual-private-server (VPS).

every other night or so sometime between 1am and 4am the VPS locks up for 10-40 minutes.

at first i thought it was somehow related to running a backup, but then i opened up a new VPS using the upgraded KVM type and had the same problem, even though there was practically nothing on the server, except for one FCGid website.

the server company is blaming it on the use of FCGid. originally i had all my websites running FCGid but that was eating up all my resources, so i changed most of the websites to CGI-wrapper instead, except for the most important ones.

my webhosting company is recommending i use suPHP instead, which i get the impression that virtualmin does not totally endorse.

from what little research i did:


it sounds as if fcgi is the preferred one.

any thoughts or suggestions? somebody is recommending i use LEMP-nginx instead, but that seems like overkill for my situation.


Hmm, it looks like you asked about a similar issue here:


We haven’t received any reports of FCGID being a problem, and it’s the default mode used for all Virtualmin installs.

There also isn’t a reason that would occur between 1 and 4am.

I don’t think FCGID is the cause of the issue you’re seeing… but determining the exact cause can be tricky.

Have you tried disabling the backups for a couple of nights? Or maybe moving them to a different time?

Outside of that – the key would be to setup some sort of monitoring on your system, so that you can see what’s going on when your server has these problems. You’d want to be able to see the system load, and process list, whenever those problems are occurring.

If you really want to, you can change the PHP Execution Mode in Server Configuration -> Website Options -> PHP Execution Mode. You can choose between FCGID, CGI, and mod_php. I really don’t think that’s going to assist with the problem you’re having though – I think setting up monitoring and discovering what exactly is occurring is the key to sorting things out.


hey eric - apologies about the double-posting. but later i realized my issue had absolutely nothing to do with backups.

i have switched the execution mode as you suggested. although now i am not really sure what caused it at all.

my web-hosting company was blaming FCGI, but i have yet to see any actual proof. i just disabled mod_perl and mod_python from apache.

my monitoring i am using is:
gotSiteMonitor.com - apache only
pingdom.com - just the server only
upTimeRobot - both, although i just starting using this one.

any other tips or suggestions are greatly appreciated.

thanks again eric!