Fatal Error Occurred: Something went wrong during installation

I’m trying to install virtualmin on ubuntu 14.04, from here http://software.virtualmin.com/gpl/scripts/install.sh, it almost throw the following error immediately after I confirm “yes”

Enabling PHP 7 PPA [>----]
[ERROR] Something went wrong with the previous command. Exiting.

If I install version 5 (From this http://software.virtualmin.com/gpl/scripts/vm5-install.sh), here are the last few lines of the log

Preparing to unpack …/libapt-pkg-perl_0.1.29build1_i386.deb …
Unpacking libapt-pkg-perl (0.1.29build1) …
Selecting previously unselected package apt-show-versions.
Preparing to unpack …/apt-show-versions_0.22.3_all.deb …
Unpacking apt-show-versions (0.22.3) …
Processing triggers for man-db ( …
Setting up perl-modules (5.18.2-2ubuntu1.1) …
Setting up perl (5.18.2-2ubuntu1.1) …
Selecting previously unselected package usermin.
(Reading database … 31047 files and directories currently installed.)
Preparing to unpack …/archives/usermin_1.720_all.deb …
Unpacking usermin (1.720) …
Selecting previously unselected package webalizer.
Preparing to unpack …/webalizer_2.23.08-1_i386.deb …
Unpacking webalizer (2.23.08-1) …
Selecting previously unselected package webmin.
Preparing to unpack …/archives/webmin_1.852_all.deb …
Unpacking webmin (1.852) …
FATAL - 2017-10-06 01:10:08 - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - 2017-10-06 01:10:08 - Cannot continue installation.
FATAL - 2017-10-06 01:10:08 - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - 2017-10-06 01:10:08 - re-attempted after any problems have been resolved.
FATAL - 2017-10-06 01:10:08 - Removing temporary directory and files.
FATAL - 2017-10-06 01:10:08 - If you are unsure of what went wrong, you may wish to review the log
FATAL - 2017-10-06 01:10:09 - in /root/virtualmin-install.log

Could anyone please help troubleshoot the installation?

Thank you very much!

How much memory does your system have?

I don’t want to see anything from the old installer; it is no longer in development or maintained and there is no point posting things about it. I will not work on the old installer. It is dead. Deceased. It is the late install.sh. It is not pining for the fjords, it has passed on. The old install.sh has ceased to be.

Give me the last 20 or so log entries from the new installer (same log file /root/virtualmin-install.log, though you’ll need to delete the log and run the new installer again since you’ve got old logs in there) and I’ll be able to give you some hints about further troubleshooting.

Hi Joe,

The error log (when using install.sh) showed that virtualmin tried to enable PHP7 in the server, but this is ubuntu 14.04 and it should have PHP 5.5.9 by default, not PHP7. I believe this is the mistake in the code.

I got migration (backup and restore the entire system) from an existing Virtualmin server so my server now is running with virtualmin without the need for installation.

The server has 1GB RAM and 512MB swap.

Thank you!

It’s attempting to enable a PPA that provides PHP7; it’s intentional, and it worked at some point during my testing, but I haven’t spent a lot of time with Ubuntu 14.04. Is 16.04 an option for you? It’s pretty solid (though Debian 9 is currently better…there’s some weird issues with the way Ubuntu sets up systemd and continues to ship upstart files, it’s an ugly mishmash of init systems, Webmin 1.9x will maybe fix our detection of that in a day or two).

I’ll try to test on Ubuntu 14.04 sometime today or tomorrow.

I just did a test install on Ubuntu 14.04. It had no problems, and was able to enable that PPA and install PHP7.

So, the question is why can’t your system enable a PPA? Can you try enabling that PPA manually and post whatever error you get?

# add-apt-repository -y ppa:ondrej/php

Actually, we’re still detecting init system wrong on Ubuntu 14.04, so that’s a bug I need to sort out. But, the PPA bit is working as designed on my test systems.

Hi Joe,

You are correct, I am re-installing virtualmin on that VPS, and see this error
add-apt-repository: command not found

So I install the package apt-get install software-properties-common and It proceeded to installation.

From the command screen, I see webmin, usermin, and postfix have been installed. It throw errors when installing virtualmin-lamp-stack.

Here is the error log

The following packages will be upgraded: gcc-4.8-base libc6 libgomp1 libperl5.18 libstdc++6 perl perl-base perl-modules 8 upgraded, 160 newly installed, 0 to remove and 159 not upgraded. Need to get 74.5 MB of archives. After this operation, 294 MB of additional disk space will be used. WARNING: The following packages cannot be authenticated! libssl1.1 libjbig0 libwebp5 libgd3 libmemcached11 libmemcachedutil2 php-common php7.0-common php7.0-json php7.0-opcache php7.0-readline php7.0-cli libapache2-mod-php7.0 php7.1-common php7.1-json php7.1-opcache php7.1-readline php7.1-cli libapache2-mod-php7.1 php7.1-fpm php7.1-cgi php7.1 php php-cgi php-cli php-fpm php7.1-mysql php-mysql php7.1-xml php-xml php-pear php7.0-fpm php7.0-cgi php7.0 php7.0-mysql E: There are problems and -y was used without --force-yes Installing virtualmin-lamp-stack: Failed with error: 100 [2017-10-09 06:07:25 EDT] [ERROR] Something went wrong with the previous command. Exiting.

I reinstall OS, tried one more time, and run the command apt-key update && apt-get update before sh install.sh, there is no difference in the error message

Actually the main reason why I wanted to install on ubuntu14.04 is because my website doesn’t work on PHP7. It seems the new virtualmin installation forces to use php7 even with ubuntu 14.04

It doesn’t force it, it’s just the default when available. You can change the version if old versions are available.

We’ve got a fixed release of Webmin coming out soon (maybe today, maybe tomorrow), that correctly detects the init system on Ubuntu 14.04, which fixes the one major issue I was seeing there. So, it may be nice again on 14.04 tomorrow. We can probably make Ubuntu 14.04 work for you, once that fix is rolled out.

Debian 8.0 is also working reasonably well and provides both PHP 5 and 7. (Though, I still really strongly suggest that everyone who can do so to use the latest supported version of your distribution.)

And, of course, CentOS 7 is the best-tested distro and the most widely used, and it supports both php5 and php7.