Fatal Error! Failed to install script : Download of https://download.moodle.org/download.php/stable402/moodle-4.2.1.zip is not an archive file - perhaps an error page

Fatal Error!
Failed to install script : Download of Downloading package is not an archive file - perhaps an error page

|System hostnamexxxxxxxxxxx.amazonaws.com (]Operating system*|Debian Linux 11|
| — | — | — | — |
|Webmin version|2.021|Usermin version|1.861|
|Virtualmin version|7.7 Pro|Authentic theme version|20.21|
|Time on system|[Monday, July 24, 2023 5:18 PM]Kernel and CPU|Linux 5.10.0-19-cloud-amd64 on x86_64|
|Processor information|Intel(R) Xeon(R) Platinum 8259CL CPU @ 2.50GHz, 2 cores|
proc/index_tree.cgi)|CPU load averages|0.21 (1 min) 0.19 (5 mins) 0.18 (15 mins)|
|Real memory|789.01 MiB used / 2.21 GiB cached / 3.78 GiB total|Local disk space|6.79 GiB used / 91.38 GiB free / 98.18 GiB total|
|Package updates|[All installed packages are up to date]


This issue was fixed already this morning. You can wait for some time to get updated version of the install script or trigger the update manually from Webmin ⇾ Webmin Configuration: Webmin Scheduled Functions page.

1 Like

Thanks for quick fix.

The version of Moodle 4.2.1 that you have provided

Requires: PHP 8.0, MariaDB 10.6.7 or MySQL 8.0 or Postgres 13 or MSSQL 2017 or Oracle 19c

[Latest release (moodle.org) Latest release

Is there a way to update MariaDB version 10.5.19 to the require version MariaDB 10.6.7?

Yes, there is a way, however it is not something we advise to do for the regular users, as it may be risky.

Virturalmin has put a version of Moodle that does not conform to the Require packages that is on server. Should you revise script to moodle-4.1.2 instead of Moodle 4.2.1 until your able to update to MariaDB 10.6.7.

It possible to edit the moodle.pl script and change the return ( “4.2.1”, “3.11.15” ); to return ( “4…1.2”, “3.11.15” );

Or was this just an typo error and Virturalmin was not using the latest version of moodle because Virturalmin have not updated to MariaDB 10.6.7

I modify the moodle.pl script to the Moodle 4.1.2 this conforms to Virturalmin server specs. It Working now. I suggest you change for other clients. To the Moodle version that conforms to Virturalmin current server specs. This just may be typo error. Thanks

We are not providing MariaDB package. Your OS vendor does. If you need a higher version of MariaDB on your server, you either need to upgrade it manually or migrate to the distro that provides this package by default, e.g. Ubuntu 22.04.

Good suggestion. I have just fixed Moodle script to support other versions, e.g. "4.2.1", "4.1.4", "4.0.9", "3.11.15" .

Again, it has nothing to do with Virtualmin. MariaDB package is provided by your OS.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.