Failed to upgrade to Virtualmin Pro - Claims I installed using the RPM, but that is untrue

I get this error when trying to upgrade to Virtualmin Pro: Failed to upgrade to Virtualmin Pro : Virtualmin has been installed from an RPM, but not using the Virtualmin GPL repository. Upgrading is not possible at this time.

Problem is, that is completely untrue. I installed Virtualmin GPL using the “” script straight from the site.

Where do I go from here?


Hmm, what is the output of these two commands:

ls /etc/yum.repos.d cat /etc/yum.repos.d/virtualmin.repo

[root@v3 ~]# ls /etc/yum.repos.d
CentOS-Base.repo CentOS-Vault.repo mirrors-rpmforge-extras webtatic-archive.repo
CentOS-Debuginfo.repo epel.repo mirrors-rpmforge-testing webtatic.repo
CentOS-fasttrack.repo epel-testing.repo rpmforge.repo webtatic-testing.repo
CentOS-Media.repo mirrors-rpmforge vz.repo

[root@v3 ~]# cat /etc/yum.repos.d/virtualmin.repo
cat: /etc/yum.repos.d/virtualmin.repo: No such file or directory

Ah, it doesn’t actually appear that you have the virtualmin.repo file there.

How did you initially install Virtualmin, was that using the script?

Also, what is the output of this command:

rpm -qa | grep wbm

If the output of the above command all looks good, then it’s just a matter of us re-creating that virtualmin.repo file.

Though, note that it looks like you have a number of third party repositories enabled there. We have seen quite a few issues come up due to third party repositories… we’d suggest caution with those, possible even disabling them until there’s a package you’re certain you need. However, that’s not the cause of the current problem you’re seeing.


Hi there - thanks for your responses. I downloaded the script from here:, set it as +x, and executed.

Output from rpm -qa | grep wbm is as follows:
[root@v3 ~]# rpm -qa | grep wbm

Okay, it looks like it’s a case of a missing virtualmin.repo file, everything else looks good. That’s created when the runs, something may have happened to that afterwards.

We can re-create that though.

What you’d want to do is make a new file named /etc/yum.repos.d/virtualmin.repo, and give it the following contents:

[virtualmin] name=RHEL/CentOS/Scientific $releasever - $basearch - Virtualmin baseurl=$releasever/$basearch/ enabled=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-virtualmin gpgcheck=1

name=Virtualmin Distribution Neutral Packages

After re-creating the virtualmin.repo file, are you then able to upgrade to Virtualmin Pro?

Looks like that fixed it! Thank you!