Failed to start The PHP 8.x FastCGI Process Manager

SYSTEM INFORMATION
OS type and version Ubuntu Linux 18.04.6
Virtualmin version 7.1-1

Hello everyone,
There is a big problem that I have been experiencing for 2-3 days on my server, which I have been using for months without any problems.

I am a stickler for updates and apply them as soon as they come. All 8.x versions of PHP stopped working with FPM Manager when I got the last update.

I uninstalled PHP 8.x, reinstalled it. My problem is not gone.

I show you some console logs:

root@srv:/home# systemctl status php8.0-fpm.service
● php8.0-fpm.service - The PHP 8.0 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php8.0-fpm.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2022-08-19 12:04:14 +03; 11min ago
Docs: man:php-fpm8.0(8)
Main PID: 28361 (code=exited, status=78)

Aug 19 12:04:13 srv.example.com systemd[1]: Starting The PHP 8.0 FastCGI Process Manager…
Aug 19 12:04:14 srv.example.com php-fpm8.0[28361]: [19-Aug-2022 12:04:14] ERROR: unable to bind listening socket for address ‘127.0.0.1:8000’: Address already in use (98)
Aug 19 12:04:14 srv.example.com php-fpm8.0[28361]: [19-Aug-2022 12:04:14] ERROR: FPM initialization failed
Aug 19 12:04:14 srv.example.com systemd[1]: php8.0-fpm.service: Main process exited, code=exited, status=78/n/a
Aug 19 12:04:14 srv.example.com systemd[1]: php8.0-fpm.service: Failed with result ‘exit-code’.
Aug 19 12:04:14 srv.example.com systemd[1]: Failed to start The PHP 8.0 FastCGI Process Manager.

I have sites running with PHP 8. There is currently no access to any of them. Can you help me?

Is one of your Virtual Servers is using socket 8000 - in it’s pool conf file?

Or one of your other versions of php-fpm using it in it’s conf file?

Cheers

Dibs

This should be fixed by re-running config check from System Settings -> Re-Check Configuration.

Also, you can switch to using sockets for PHP-FPM using System Settings ⇾ Server Templates: Edit Server Template / PHP options page.

1 Like

Yesterday it was 8005. Pretty odd.

How can I check what you said?

“Re-Check Configuration” did not fix the problem.
In the Other PHP Options section, I don’t know what to do.

Try to disable PHP execution mode or switch it to FCGID first and then back to FPM-PHP.

Very strange things are happening on the server.
Now it started giving this error.

… failed : Job for php7.4-fpm.service failed because the control process exited with error code. See “systemctl status php7.4-fpm.service” and “journalctl -xe” for details.

I’m losing him a little more every minute.
After importing to FCGID, Internal Server Error occurred on many of my sites.

Run

lsof -i :8000

to see what is using port 8000. That should point you in the direction of what php-fpm is conflicting with when it tries to start up on port 8000.

HIH

Dibs