Failed to start service : Failed to start BIND

I’ve had to rebuild Virtualmin and had my websites running, but now they’re not running.
Virtualmin > System Information won’t start the BIND DNS Server.

I select the green arrow to start the BIND DNS Server and receive the error:
Failed to start service : Failed to start BIND : Starting named: Error in named configuration: zone localhost.localdomain/IN: loaded serial 0 zone localhost/IN: loaded serial 0 zone loaded serial 0 zone loaded serial 0 zone loaded serial 0 zone NS ‘’ has no address records (A or AAAA) zone NS ‘’ has no address records (A or AAAA) zone not loaded due to errors. _default/ bad zone zone loaded serial 1373699158 zone loaded serial 1373699353 [FAILED]

I have research the Internet, however I’m hoping this forum might have some helpful suggestions.

Here are the details from Virtualmin > Webmin > Servers > BIND DNS Server > Existing DNS Zones > Zone: > Edit Records File

$ttl 38400
@ IN SOA localhost.localdomain. root.localhost.localdomain. (
38400 ) IN A IN A IN A IN A IN A IN A IN A IN A IN MX 5 IN TXT “v=spf1 a mx ip4: ip4: ?all” IN NS IN NS

Well, like the error message states, your zone does not have address records for your nameserver records. You can try recreating the zone by turning the BIND feature in Virtualmin off and on again for the domain in question. If that doesn’t help, i can offer you to take a look at your system myself, since the problem can have too many reasons to guess here. :slight_smile:

Thanks, unable to shutdown the BIND DNS domain feature in Virtualmin > > System Settings > Features and Plugins.

I’m aware I need to remove the feature from each Virtual Server, however I have not found how to do this yet.

Happy to have you take a look if you like.

Problem is the server died and no restore’s worked, so it’s a fresh build and did work, but this BIND DNS error came up?

Do you have this issue with all your domains? Well, you can use the command line API to turn off and on the BIND feature on all your domains like so:

virtualmin disable-feature --dns --all-domains virtualmin enable-feature --dns --all-domains

This should recreate all zones for your domains. If you still have missing A records then, let me know. I’d need to take a look at your templates and config then myself, for which I’d need root access to your Virtualmin and SSH shell.

Thanks, that worked.
Websites still not showing so tried Virtualmin > System Settings > Re-Check Configuration and needed to add
This let Re-Check complete the check with no errors.
However, still no websites.
Not sure if this is a problem, but the Webmin > Others > File Manager > home > mydomain > public_html > index.html > Preview shows error:
index.html is not in a supported format.
If I double click on index.html it shows the webpage.
Still no WAN access.

Sorry, I can’t follow you there… “no websites” how? What’s the problem exactly? And what do you mean with “no WAN access”?

Hmm, I’m having trouble finding what the error is, so the typical troubleshooting I do shows the following:


; <<>> DiG 9.9.2-P1 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26233
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1280
; IN A

;; Query time: 29 msec
;; WHEN: Mon Jul 22 08:20:44 2013
;; MSG SIZE rcvd: 48 says is down.

Where did you run that “dig” command?

Was that run on your Virtualmin server? Another server on the LAN? Or a server somewhere out on the Internet?


Thanks for the reply.
I ran the dig command on a local computer.
I have now SSHed into the Virtualmin server and the results are below.
Note the SERVER result’s IP address is the router (router is port forwarded to Virtualmin server for ports 53, 80 and 10000).


; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46923
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

; IN A

;; Query time: 30 msec
;; WHEN: Mon Jul 22 13:07:35 2013
;; MSG SIZE rcvd: 37

This almost looks like your recreated zones are empty or you’re digging the wrong domain… I guess it’s time to take a look at the system myself, everything else is too much guessing. :slight_smile: If you’d like that, let me know your contact details on an instant messenger of yyour choice.

Thanks for the reply.
My pseudonym on Skype is: Virtualmin Fix.

I think maybe the IP addresses are causing the website not to show, but not sure?
Webmin > Network Configuration > Network Interfaces > eth0:1 > IPv4 address > Static configuration > IPv4 address: > Netmask: > Broadcast:

I sent you a Skype message and am waiting for confirmation.

Thanks for the reply.
I just opened up Skype and no message unfortunately?
My Skype username says Virtualmin Fix, on the top left of Skype.

Hm, Skype seems to have some trouble at the moment. It ignored my user add and right now I can’t even sign in.

Are you using any other instant messenger?

Hi, how about Yahoo messenger? My handle there is fixing_things.

Sorry, I’m not using Yahoo anymore, since only one or two people during my 10+ years of instant messenging used it, and all of those are using other services too. :slight_smile:

I can offer Trillian Astra, ICQ, AIM, Skype (doesn’t seem to work with you), and Jabber (preferred).

Hi, okay, I set up Pidgin (I think it’s Jabber based). My nickname is fixingstuff.

For Jabber, I need a full JID in the form username@domain.tld.

Okay, I’ve set up
Hope this works?