Failed to start service : Failed to start BIND : Starting named: [FAILED]


I am running:
Operating system CentOS Linux 5.3
Webmin version 1.470
Virtualmin version 3.69.gpl GPL
Theme version 7.1
Kernel and CPU Linux 2.6.18-128.1.10.el5 on i686

My bind wont start, was working fine then virtualmin did a upgrade I think for Ruby and Python.
did not complete it I think.

I then later noticed that Bind was not working

Now wont start Bind says:

Failed to start service : Failed to start BIND : Starting named: [FAILED]

If I log into my domain via the ip address and run under bind server “Check BIND Config”


No errors were found in the BIND configuration file /var/named/chroot/etc/named.conf or referenced zone files.

saw this command used on one thread not sure if it helps.

ps auxw | grep named


ps auxw | grep named
root 11900 0.0 0.2 2448 1020 ? S 14:21 0:00 sh -c su root -c ps\ auxw\ |\ grep\ named 2>&1
root 11901 0.0 0.2 2832 1104 ? S 14:21 0:00 su root -c ps auxw | grep named
root 11902 0.0 0.1 2404 900 ? S 14:21 0:00 bash -c ps auxw | grep named

Does not give the same reslts as they had.

Also where can I find an error log for bind as the error message I got helps me zero.

You might want to take a peek in /var/log/messages right after restarting BIND. If it’s generating errors, they’ll probably show up in there.


Hi Eric

Only thing I found is that Yum was busy around the time when it happened.

Sep 19 09:57:03 Installed: 30:bind-chroot-9.3.4-10.P1.el5_3.3.i386
Sep 19 09:57:10 Updated: python-2.4.3-24.el5_3.6.i386
Sep 19 09:57:11 Updated: libxml2-python-2.6.26-
Sep 19 09:57:12 Installed: 30:bind-chroot-9.3.4-10.P1.el5_3.3.i386
Sep 19 10:27:32 Updated: ruby-libs-1.8.5-5.el5_3.7.i386
Sep 19 10:27:33 Updated: ruby-devel-1.8.5-5.el5_3.7.i386
Sep 19 10:27:34 Updated: ruby-1.8.5-5.el5_3.7.i386
Sep 19 10:27:34 Updated: ruby-irb-1.8.5-5.el5_3.7.i386
Sep 19 10:27:35 Updated: ruby-rdoc-1.8.5-5.el5_3.7.i386

This is what it was busy doing as far as i know.

Can this effect Bind at all if it hangs during this.

I have already restarted the server (Dedicated) and same problem.

Is it possible to give you the root password for you to have a looks
as there are 32 domains on the server and I cant find anything.



So when you restart BIND – what shows up in the message log? There should be at least some messages from BIND, even if they aren’t errors…



does not exist


but no messages file or directory.

what happens if you update to the latest virtualmin version?

I am running

Virtualmin version 3.69.gpl GPL Theme version 7.1

but don’t know if it will help as an update most probably will just carry the error over as settings are kept
Bind Check says its all okay.

that older version does not detect anything wrong in BIND.

The newest version may detect something wrong in BIND. I don’t know but why not update to Webmin version 1.480 and Virtualmin version 3.73 anyway?

Yeah, it sounds like something is awry with your logging – as /var/log/messages should exist on all servers.

In the meantime, however, try running this command to try and coax BIND to show you some error messages:

/usr/sbin/named -u named -f -g

Then, paste in the output you see on the console, that will hopefully show what the issue there is.

I do agree with Ronald, though, in that I’d recommend upgrading Virtualmin… keeping up with software updates is important, and the version you’re running has some security issues in it :slight_smile:


I was checking my configuration in named.conf file and found that its firsst entry refers to this

options {
directory “/etc”;
pid-file “/var/run/named/”;
allow-recursion { localnets;; };

Iwent and looked at


but the directory /var/run/named/ is empty, no file
could this be the problem.


How do I up grade it, I also see its still using Bind 8 and not Bind 9.

This was a fresh install this year still so thought it was up todate.

Will go do the command and get back to you



Its been running the command now for about 8 minutes with no output yet,

I noticed that my email suddenly downloaded a few emails from this domain, not many usually gets quite alot, but when I checked it still showed stopped in the system info summary.

but when I tried to start Bind now I got a different error

Failed to start service : Failed to start BIND : Starting named: named: already running[FAILED]

Not sure if that helps at all.


In Vitualmin if I click “System Information”
Status shows that everything is up except Bind.

But the domains are now showing and mail downloads.

Am to “scared” now to touch anything as Clients are now quite as I have 34 domains on the server.

Any ideas as to whats happened would be great.

its been working since I ran that command you gave me,
but there was no output.


Failed to start service : Failed to start BIND : Starting named: named: already running[FAILED]

Yeah, that message there suggests that BIND had already been started.

As for what happened to cause all that – I honestly have no idea :slight_smile: That’s all very unusual, and the idea that the server doesn’t have logging available in /var/log/messages is equally odd.

Also, the command I gave you should not have fixed it, it should just have temporarily enabled some debugging info. It didn’t even work, actually, as the error message above suggests BIND was already running when you ran that :slight_smile:

So it sounds like something you did got things running…


Yay For me just wish I knew what it was incase there was a next time.

Any idea as to how to get the logs up.

Also how do I go about upgrading to newest version of Virtualmin without loosing domains etc.
Would also lke tp go up to Bind 9

Thanx again Eric for the help always there as usual :slight_smile:

Mmm – you may just want to make sure Syslog is running – try running this:

/etc/init.d/syslog restart

also a ‘yum update’ should bring your system up-to-date. If not, I’d suggest to run ‘yum clean all’ and then ‘yum update’.

‘yum update webmin’ should also work for updating webmin

When I run Yum Updaye it gives me a list of updates and ends of with this:

Install 3 Package(s)
Update 30 Package(s)
Remove 0 Package(s)

Total download size: 56 M
Is this ok [y/N]: Exiting on user Command

But nothing appears to have happened.