Failed to start service (Apache Not Starting Up)


I just started to use Virtualmin and I successfully added my top level server and it’s working like a charm however, the sub-servers are no good. Every time I add a sub-server, apache fails to startup and gives the following error:

Failed to start service :

Starting httpd: Syntax error on line 1189 of /etc/httpd/conf/httpd.conf:
can’t get fastcgi file info: /home/server/domains/, errno: 2

If I remove the newly added sub-server, apache starts again! I think there’s something wrong in the settings…

I have already migrated my main website to this new server and I am not too good at those geeky stuff, so, I am not going to try anything out by myself because I don’t wanna mess anything up here! Any help?



One thing you might try is to switch away from FastCGI/FCGID to ordinary CGI, and see if that move resolves the issue.

To do that, first re-add your Virtual Server.

Once you’re finished, if Apache still won’t start, go into Virtualmin and to the following:

  1. Select your sub-server from the dropdown list on the top-left

  2. Click Server Configuration -> Website Options

  3. Where it says “PHP script execution mode”, choose the “CGI” option

After doing that, see if that fixes up the issue you were having.

You’re seeing an unusual problem though… I’m curious, what Linux distribution/version are you using? And did you install Virtualmin using the script?


Everything seems to be ok now. I edited some stuff in the Apache website section of server templates!