Failed to save scheduled backup : Deletion of old backups is only supported when a date-based destination is used, and strftime substitutions are enabled

Failed to save scheduled backup : Deletion of old backups is only supported when a date-based destination is used, and strftime substitutions are enabled

This fellow is a repeat offender. He posts just the error messages that show up on his system without including in his post any other description or explanation - not even the OS and version of of Virtualmin on his system - and expects the community to guess how best the error might be resolved.

If @anuj9122 is too busy to take the time to properly describe his situation, should we in the community attempt to assist him at all?

Sorry Calport for not giving full details.

OS: ubuntu server 20.04
Virtualmin:- 6.16

Actually I want to ask which format give file name in scheduled backup. Also enable old after 11 days.I want scheduled backup (Vitualmin) take backup everyday at 3:00 AM and save to local drive folder name and location at /serverbackup.

Please see screenshot. When i am doing same as in screenshot. i get this error. File name too long.

Why are you using % in your file name structure? That is a no-no and should never be done. If it’s not you doing that, then you’re using some sort of special character that you shouldn’t be using.

i am trying

https://archive.virtualmin.com/node/12063

Anyway. please tell me correct file name.

Try this:

Go to where you are - Backup Virtual Servers
Select the Local File or Directory
Click on the Folder and select the Home folder. Don’t type anything in there. (your arrow is actually covering the folder icon)

Select one file per server, not one big file.

Down where it says backup compression, select zip.

Hit backup and see what happens. If it goes through, the backups will be in the home folder on your server and you can use your file manager to download it from there or move it where ever you want it.

Let’s just get it working first.

This one is working. I need it in scheduled backup. I want scheduled backup to be deleted after 11 days and also i need single big file. The problem is in file name format.

OK.

So let’s try this - Do exactly what you just did except these changes:

When you select the home folder, then select single file backup, go back where the home folder is listed in the blank and put a slash and name in there. Keep it simple. It should look like this:

/home/backup.zip

Then hit backup and see if it works. It should.

Then, when it’s done, you should be able to hit OK and a window should open that lets you set another backup schedule. It will use those settings to do it.

Please check screenshot


Those are not valid strftime substitution variables.

You probably want something like %Y/%m/%d

The strftime man page has all the variables: Ubuntu Manpage: strftime - format date and time

1 Like

That’s the prefix for strftime variables, but they’re not using them correctly. Ubuntu Manpage: strftime - format date and time

1 Like