Failed to modify server: A MYSQL login named [user] is already owned by virtual server [subdomain]

Okay, So I am moving servers at the moment.
It’s a bit of a tricky case, because of one particular site, first all the subdomains have to be moved, and only later the main domain.
But all the subdomains are made as sub-servers, so no problem right?
On the new host I created a new server for the main domain (, user example, just like on the old host) and started to import backups from the old server.
During the creation of the main domain, I might have forgotten to enable MYSQL.
Everything went great. I only noticed the main domain had a wrong setting. The allocated space was not enough and I need the password to be reset for some testing.
So naturally, I go to virtualmin > select domain > edit virtual server and make the changes I wanted to do.
After clicking apply, I get the following error:
Failed to modify server : A MySQL login named example is already owned by virtual server

Ok, So I went to that subdomain to check the users, but user example is not in there. Next stop: the MYSQL server. I go Webmin > servers > MYSQL Server > Database permissions.
I notice that the user example has rights on each database, so I removed all these permissions. The user example is not listed as a mysql user.

I tried to make the changes again in the virtual server, but failed with the same error.

How can I solve this problem?