Failed to lock file /etc/postfix/virtual after 5 m

I would like to delete a server and am running into this problem through a browser and through ssh - running usr/libexec/webmin/virtual-server/ script… Anyway around this?


Yeah, that seems to occur on rare occasions – what I would do is:

  1. Restart Webmin – /etc/init.d/webmin restart

  2. Verify that there aren’t any .lock files in /etc/postfix, by typing: ls -a /etc/postfix/

  3. If there are, delete the lockfiles (but not the "virtual" file :slight_smile:

  4. Try deleting your server again

That should do the trick!

No lock files. I just tried again and all went well, so it seemed.

I am trying to migrate a cpanel account that is 11gb in tar size but when untarred is 39gb. I believe some of the settings for creating accounts is causing a problem. Here are some things I noticed.

  • server was deleted from virtualmin panel, but after "importing" domain it says the server is using 19gb, though it was just created and no files added. Note the word "importing" not, migrating.

  • Before deleting the server, I noticed all the files for the server were in their proper places. But the databases were created but not populated. I tried to populate the db with a tool I have (Navicat) and got an frm error. So, I removed the db and created a new one with a different name and tried again. Got the same error. I then went to change the space limit for the server, and made it unlimited. Then I was able to import data to the tables.

I would like to start from scratch, to migrate this cpanel account, but I am afraid I will always bump into this disk usage problem. I believe last time the migration timed out or quit because the account was over it’s usage. Unfortunately, when migrating, you don’t have an account plan option, but server template option to choose from. I did make an unlimited account and server template but that will be no use when migrating, as the disk usage settings are tied to the account plan module.

Any tips? BTW, I did upgrade the server this evening and tried again before posting…


Hey, Thanks for the solution.

It worked for me.