Failed to create virtual server : Invalid master IP address : none

hello all,

when i try to add a new server, i get this message
Failed to create virtual server : Invalid master IP address : none
This is a new installation with no servers at all…

Operating system Debian Linux 9
Webmin version 1.953
Usermin version 1.802
Virtualmin version 6.10

Since it’s a new server, you could wait for 6.11 to be released any day now; or immediately in Network Settings, Turn Off Detect Automatically and manually apply your shared IP address.

I don’t think there are any known bugs in 6.10 that would effect this? I think it’s just a weird network config on the system in question and we couldn’t detect the IP. Setting it manually is probably the right thing.

The IP is not detected - regardless of version of Virtualmin. Thanks for confirming that, @Joe. You had better apply it manually @Paok1926. Sorry about the confusion.

I’ve had that happen with Virtualmin and other panels when using hosting companies that use DHCP with reserved assignments to assign IP addresses, which is fairly common on VPS’s. Manually setting the IP address(es) is the fix.

I also have to make /etc/resolv.conf immutable ( chattr +i /etc/resolv.conf ) in that situation to prevent the nameserver configuration from disappearing every time the server is rebooted. That’s on CentOS. I don’t know about Debian.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.