Failed to activate interface : sh: ifup: command not found

OS type and version RHEL 8.8
Webmin version 2.101

Trying to add a virtual interface to an existing NIC.

Save and Apply = Failed to activate interface : sh: ifup: command not found

Should it be using NetworkManager?

Yes, it should, if that’s how your system network is configured.

I can’t think of any reason for it to be doing otherwise, unless you’d previously used Webmin network module to create configs (from before Webmin had Network Manager support) and it has some leftover config files that are confusing it into thinking it can use the old system. Something is making Webmin think it can use the old system, anyway.

@Jamie, any thoughts on why a Network Manager system would still be trying to use old stuff that isn’t there in Webmin 2.101?

It was a clean Minimal install yesterday.

Checking a snapshot from immediately after the install, there is already a file /etc/sysconfig/network-scripts/ifcfg-ens192 with the settings in it.

I found this in an article.

Before we go further, the following are some other important points to note about networking in CentOS/RHEL 8:

  • The traditional ifcfg type configuration (eg. ifcfg-eth0, ifcfg-enp0s3) files are still supported.
  • Network scripts are deprecated and are no longer provided by default.
  • A minimal installation provides a new version of the ifup and ifdown scripts that call NetworkManager via the nmcli tool.
  • To run the ifup and ifdown scripts, NetworkManager must be running.
    How to Manage Networking with NetworkManager in RHEL/CentOS 8

I can only find: /usr/lib/dracut/modules.d/35network-legacy/
with no ifdown anywhere

There don’t appear to be any active config files in /etc/NetworkManager

I also tested that NetworkManager is active, enabled and running.

Perhaps I have to do something with NetworkManager tools for it to create some files and then be recognised by Webmin?

So, that’s probably why Webmin is confused. It found configuration for the old style network config, but the old network tools aren’t actually installed. I dunno what to make of that. (But, we probably shouldn’t try to use old commands that aren’t existent when new configs do exist.)

The trick is to run:

nmcli connection migrate

Then Webmin is happy. Not tested it much yet though.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.