Failed install Error:: Failed to open PID file

SYSTEM INFORMATION
OS type and version Ubuntu 20
Webmin version 7
Virtualmin version 7

When trying to install virtualmin on a server installation seems to go fine but when it get’s to configure:usermin I get an error:

Configuring Usermin ▒▒▒Error: Failed to open PID file
Error
Failed to open PID file

I tried to configure it manually by using virtualmin config-system --include Virtualmin but I am getting the same error.
Configuring other components are running fine.

One thing to mention is that I have preinstalled MySQL v8 since I wanted to use mysql instead of MariaDB. Not sure if that would cause it but I figured I’d post…
Issue seems to be the same as How to install a fresh VirtualMin server on Rocky/Alma Linux 8 right now? - #3 by cmeis
Thank you

That’s the Virtualmin plugin of virtualmin-config. Your error is in the Usermin plugin.

Edit: Ilia tells me he’s tested pre-installing MySQL with good results with our more recent stack packages, so I guess that’s the thing to do now. So, I’ve removed my comments about not preinstalling MySQL. That’s fine as long as you’re using MySQL from the OS standard repos. (But you should stick with MariaDB unless you have a compelling reason not to.)

1 Like

What is the output of status command for usermin, i.e.:

systemctl status usermin

Can I login to your system and have a closer look at what’s happening?

Sure,
Want to DM me?

DM sent.
Started a new server without installing anything and having the same issues

Alright, thanks.

The problem was with SSL certificate for Usermin, which wasn’t generated properly.

I patched your system to address the problem.

For anyone seeing this problem the temporary solution would be to run:

cp -f /etc/webmin/miniserv.pem /etc/usermin/miniserv.pem
systemctl restart usermin

Thanx you!
Is this caused by something I missed? Or an error in the install script?

Thanks.

Is this caused by something I missed? Or an error in the install script?

No, this is our bug.

@Jamie, you have a bug in your Usermin build script, which supposed to resolve the link to the new ../webadmin/miniserv.pem (2.89 KiB) upon build but instead it uses very old and no longer working miniserv.pem file (974 bytes) … and, in case openssl command fails in the scriptlet (i.e. setup.sh) then Usermin won’t be able to start.

In other words, just make sure to put ../webadmin/miniserv.pem to usermin package.

Do I need to run anything else after? Meaning does the install complete successfully besides for this? Or do I need to resume install?

@Ilia where is this old miniserv.pem coming from? In the current Usermin repository, miniserv.pem is already a link to ../webadmin/miniserv.pem

@Jamie I know that it is, and in my nightly builds it’s correctly linked but in production builds the old miniserv.pem is coming out of the blue. Therefore, I assumed that there is something happening on your built system.

I don’t remember if I ran virtualmin-config-system -i Virtualmin on your system. I would suggest running this and that’s it. You cannot resume the install.

@Ilia are you seeing this in the Debian, RPM or tar.gz packages of Usermin?

@Jamie, false alarm. It is not an issue in 1.861 … I was looking into 1.860 packages.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.