Failed backup of Virtualmin error

I’m getting this error:

Subject: Failed backup of Virtualmin on to /virtualmin_backup/maandag/xx-xx-xx on FTP server

Creating backup for virtual server
Copying virtual server configuration …
… done

Backing up Cron jobs ..
.. none defined.

Copying records in DNS domain ..
.. done

Saving mail aliases ..
.. done

Saving mail and FTP users ..
.. done

Backing up mail and FTP user Cron jobs ..
.. none to backup

Copying Apache virtual host configuration ..
.. done

Copying Webalizer configuration files ..
.. done

Copying Logrotate configuration ..
.. done

Dumping MySQL database websitename ..
.. done

Copying Procmail and SpamAssassin configuration files ..
.. done

Backing up Webmin ACL files ..
.. done

Backing up AWstats configuration file ..
.. done

Backing up DAV users file ..
.. done

Creating backup of Mailman mailing lists ..
.. no lists found

Creating TAR file of home directory ..
.. done

Uploading archive to FTP server ..
.. upload failed! Failed to read reply to initial connection

… completed in 2 minutes, 12 seconds

But the strange thing is that when I navigate to the location where the backups are located, then you’ll see the backups and nothing is wrong with these backups. But I want to know why my virtualmin server is giving me this error. Can anyone help me?

My FTP is a NAS server ny the way.

With kind regards,



Hmm, do you receive that same error for each backup that’s being uploaded?

Also, does your NAS have an option to use SSH rather than FTP? I’m curious if you have better luck with that, or if you receive the same error.


Hello Andrey,

Yes I do recieve the same error for each backup that’s being uploaded. That’s the weird thing, but these backup files are uploaded to the NAS, but it still gives me this error.

There is a SSH option on my NAS, but I prefer to use FTP, cause it’s a standard protocol that we use here. But if there is no other solution to try to fix this error then I will think about it.


My NAS does not have a SSH option unfortunately…


Guess the FTP on my NAS is bringing me the wrong information (what I already expected). I’ve tried to backup to another FTP server and everything worked correctly. No errors were found. But I still can’t figure it out why my NAS is giving the server the wrong information?

I have a ZyXEL NSA-220. Maybe some of you know why?

Kind regards,

I’m unfortunately not sure why you’re seeing that particular issue… my only thought would be to review the logs on your NAS, as maybe there’s a more detailed error message on there.