Extracting the backup _dir folder via 7-zip shows multiple numbered folders in public_html

Hello everyone!
I switched to Virtualmin 1 week ago from another panel that I have been using for years. Everything is great!
I have migrated all sites and now I want to set up backups.

Virtualmin archives the archive file named _dir as several folders.
How can I extract it in one piece?

Merging would be a terrible waste of time for me if I had to do a manual import.

When I open the _dir archive “.” I am encountering the folder. It contains directory names made up of numbers.

I want the public_html folder to be one piece like this.

OS type and version Ubuntu Linux 18.04.6
Webmin version 1.984
Virtualmin version 6.17-3

When I backup using Virtualmin, it does that with a single tar file per domain, per day etc. You can customise this using the date format. I can the restore sections, web dir, email files etc. as per restore options. These backups are not designed for you to unzip and restore individual folders, the system will restore for you.

When I backup using the file system backup, I do this when above isn’t specific enough or I want more control of random folders I backup. Again, using date format I do per day/date/ per domain etc. You can use this backup service to zip up your public_html if you don’t want to use the backup service as above.

What are you trying to do?

I simply showed the problem, please watch:

He split the public_html folder into multiple sections.
Actually, I can combine all public_html folders into one folder, but this is terrible for large files.

Folders like “etc, cgi” are separate yes, no problem.
But I want public_html to be one piece.

If one day I want to leave Virtualmin, how will another panel merge these disparate folders?

Doesn’t make sense for a universal backup. I want all files to stay in one place in public_html.

Is this possible?

On standard Virtualmin installs, virtual servers are placed inside the /home directory thus:


Now, inside each virtual server is a public_html directory thus:


And inside this public_html is content that the owner of the virtual server / user uploads.

In the vid that you recorded, I see a few numbered directories at the beginning of the recording. What is the relative path to those directories in your archive? We need to know this before we can tell you anything definitive.

The only wild idea I have at this point is that your archive is so large that the archiving utility is somehow splitting one directory into multiple numbered directories to manage the archive internally, but that is an explanation in the absence of any other reasonable explanation.

If you try to use Virtualmin backup on a known small sized virtual server / domain, do you still see numbered directories or is everything in public_html as you would expect?

Thank you for your interest.
I have now made a backup of my server using the Virtualmin “Scheduled Backup” option. The size of the public_html archive file of this server is “40.69 MiB.”

Then I downloaded this backup as “.tar.gz”.

Now I want to show you a gif of extracting “.tar.gz” and what happened next.
Please watch this with care: 2
1- I downloaded the backup directly via FTP.
2- I started extracting with “.tar.gz”.

See how it then shreds a directory that isn’t even 100 MB?
If this isn’t a problem unique to my server, it’s terrible.

You are dodging the question. What your archive is doing after you download it isn’t relevant.

The question is: HOW are you engineering your backup? Read this question again and answer it:

1 Like

My backup settings is here:

They aren’t all in one public_html in the backup because they aren’t all in the same public_html on the server.

1 Like

Hello Joe,
Maybe I should explain the problem more clearly.

Different servers have different public_html from each other, that’s true.

My problem is this:
When I make a backup of a single site, the result is still the same.
The fragmented public_html I posted above is a backup of a single site.

When you back up your home directory it is going to back up every virtual server you have in that directory separately.

Go to the Webmin tab and look under tools and hit the file manager. Then go to the home directory. That will show you the entire file structure that you’re actually backing up and then you’ll understand why things are where they are.

I don’t know how to explain my problem more clearly.

I only choose 1 website when backing up. So 1 server. There is a simple Wordpress installed.
It shatters its public_html folder.
I `m talking about this.
There is not more than one site involved.
There isn’t a huge amount of data. (100MB)

It even shreds the backup of 1 site.
That’s my problem.

Here is a piece of your screen shot with the highlighting done by me:

home directory backup

Here is what is inside my home folder on a test server I use that only has one domain on it:

home folder

You are not just backing up one site. You are backing up the ENTIRE home folder.

i had same problem.
is 7-zip…

try to open with winrar and show correctly subfolders…

ps. of course if backup is full backup (include home directory)


This is the real solution to the problem.
But this is ridiculous!

As a 7-Zip fan, I didn’t like it at all.
Even a stupid program like Win-rar can open it correctly, but is 7-Zip the source of this problem? my god!

Thank you so much.
Now my public_html directories are one piece…
again. Nonsense!

i agree…

i’m 7-zip fan too , but i don’t know why this problem.
but some time ago i tried with winrar and works…

but, i have not idea why…

i’m happy to help :slight_smile:

I have no experience with 7-zip, but I can say that Virtualmin backups are standard tarballs made with GNU tar (or whatever tar is on your system, but all of our supported Linux distros use GNU tar). It’s Open Source, and the most popular tar implementation in the world. We literally could not make it more standard or more accessible across any platform than using GNU tar.


Thank you to everyone who tried to help.
Good luck everyone.

I confirm the issue with 7zip and PeaZip, and it has been experienced by many others:

Given the frequency of issues, I think the best would be a zip export without tar.


1 Like

Maybe 7-zip should fix their tar implementation?