Extract backup file


I have a backup file that was created by Virtualmin (one file per server old format). The file was domainame.tar.gz which i can extract fine with WinRar on Windows. Once extract there are a bunch of files and I know the files arein domainame_dir, however since this file has no extension I dont know which program to extract it. I tried renaming the file to different types (like zip, tar.gz, and …) but it’s not working. I dont want to restore all the files but only some of them.

I know I did successfully extracted it before, but I forgot how -_-"

Thank you in advance.



Did you ever figure this out? I also need this, I need to get some files out of a backup, and the database, I just see a mydomain_dir file and a mydomain_mysql_xx file!

I think I ended up going another way, but I forgot again what I did :frowning:

Did you?

No I never figured it out.

I always have to login via SSH, tarball it up, download or SCP it somewhere, and untarball it. Then use PhpMyAdmin to get the DB. So its much longer this way than running taking a backup and extracting, so I hope we can find out how.

domainname_dir might be an uncompressed .tar, did you try that? I know you can see file contents in clear text in there, and I seem to recall that there’s a step “Creating TAR of home directory” step during backup.

This is a file though, not a directory. And if I add the extension .tar, and try to extract that, it does not work (tried it before!). Also tried renaming to .zip and .tar.gz and then extracting and neither work.

So my guess is its some other compressed filetype or something only recognised by Virtualmin.

I just tried it with Total Commander from Windows (same applies to Midnight Commander on Linux)… Using the “domain_dir” file as a TAR archive works okay. Extraction was no problem.

What error exactly do you get when you try it? You need an archiver program that supports TAR of course.

I am on a MAC. I add in a .tar suffix on the file. Then when I double click it to extract it, it goes through the extraction process, then right at the end says:

Unable to expand “xxxxxx_dir.tar”
into “Desktop”
(Error 1 - Operation nor permitted.)

Okay, you might try it on a system/software then that supports tar files. Your Mac apparently doesn’t.

Well Mac does support Tar, its a Unix based system, tar works fine in command line and desktop (double clicking .tar files). Thats the point. Virtualmin xxx_dir file with .tar extension added does not extract, so maybe something different about it as other tar files work just fine on a Mac.

Well I don’t know… All I can say is that those Virtualmin-generated TAR files extract fine on my Ubuntu and Windows 7 systems.

Just to be clear, I’m not talking about the backup file itself, which extracts fine. I’m talking about the mydomain_dir file which is in the backup file and what looks to contain the file system. This is the file we can’t extract to get the actual website files with in. This is what I added the .tar suffix to and can’t extract.

If you say this works on Ubuntu I shall try on my Ubuntu soon.

Yep I know what we’re talking about. :slight_smile: I’m talking about the same. The “DOMAINNAME_dir” file inside the backup archive. It contains the home directory of the virtual server. Try it on Ubuntu, it works fine there for me. Except, well, the backup you have there might just be corrupted or so.

I had this same issue on a mac. I was able to extract the file using Terminal (command line).

get to the directory that the file is in and use the tar command, I used “tar xvf”.