External Connectivity Check fails

Error message

Failed to check connectivity	
HTTP/1.1 503 Service Unavailable	
Verify that your DNS server is running, that software.virtualmin.com can be resolved, and that no firewall is blocking outgoing HTTP requests

Ping OK

[ns2@ns2 ~]$ ping -c1 software.virtualmin.com
PING software.virtualmin.com ( 56(84) bytes of data.
64 bytes from 254-162-172-163.instances.scw.cloud ( icmp_seq=1                                                         ttl=47 time=117 ms

--- software.virtualmin.com ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 116.839/116.839/116.839/0.000 ms


[ns2@ns2 ~]$ wget --spider --tries 1 --user-agent ExternalConnectivityCheck  software.virtualmin.com                                    Spider mode enabled. Check if remote file exists.
--2021-12-06 13:39:09--  http://software.virtualmin.com/
Resolving software.virtualmin.com (software.virtualmin.com)...
Connecting to software.virtualmin.com (software.virtualmin.com)||:80... connected.
HTTP request sent, awaiting response... 401 Unauthorized

Username/Password Authentication Failed.

Wget with --user --password
→ also failed.

OS type and version: CentOS 8
Webmin version: latest
Virtualmin version: pro latest
Related products version: RECOMMENDED

this :

isn’t the same as wget results… :

don’t know about virtualmin’s connectivity checks, but,
error message, and your wget test seem irrelevant.

Wget with --user --password
→ also failed.

I don’t know what they use to authenticate against software.virtualmin.com. But I tried both my Virtualmin account and Virtualmin Pro license credentials; Both failed.

Try software.virtualmin.com/gpl URL.


Well, it worked with wget; But why is it failing on virtualmin:10000?

I have no idea what virtualmin:10000 is in this context.

Oh, it is my hosting/server.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.