Exicute PHP by CGI as server owner creates database errors

I am not sure if this is a problem with Virtualmin or something else with my setup ( Ubuntu10.04 ), but I first encountered it after using the install.sh script and then again after doing a manual build with the Virtualmin module. Either way once I activate the suexec module and exicute php with CGI as server owner, I encounter the same problem with drupal loading the module page slowing timing out and even corrupting the database.

Anyone know why this happens?


Hmm, that’s all very unusual, I’ve never heard of an issue like that.

Some folks have seen that with PHP 5.3.x, they need to set this parameter in $HOME/etc/php.ini in order for things to work properly:


Also, do you see any errors in the Apache error log, located in $HOME/logs/error_log?


I forgot to mention, I even downgraded the php to 5.2 because I thought that was the problem since in the past drupal 6 had problems with php5.3. But It seems to make no difference between php5.2 and php5.3.

For the error logs, it just shows that the php script running, is timing out but, it is not a matter of increasing the execution time or memory limits. The page hangs for minutes before going to a permanent failure message.

It doesn’t happen right away on installation either. It only occurs once you enable modules such as update status, multisite manager and others. Basically, once you get your database to a certain size, it seems to have trouble. But switching back to php_mod eliminates the whole issue. The trouble is I prefer the run as server owner mode.


What about using FCGID – does that by chance resolve the issue? Or do you run into the same problems with it as you have with CGI?


No, that has the same effect. As far as I can tell it must have something to do with running as server owner.

I have tested this multiple times on a fresh setup of the install.sh and a manual build. I Don’t know what is causing it, Ubuntu, webmin, or virtualmin. I think somebody with more knowledge than my self should try running drupal with ubuntu 10.04 and virtualmin and see what happens. Not just a fresh install of drupal, add a bunch of modules to drupal and see what happens while exicute php as server owner is enabled.

thanks for all your help,

Well, the cgi.fix_pathinfo change I mentioned can also correct issues on more recent PHP 5.2.x builds.

You may want to try this in your $HOME/etc/php.ini file, log out of Drupal, and then log back in, just to rule it out as well (if you hadn’t already):


I tried adding “cgi.fix_pathinfo=0” to the end of the php.ini file. But now turning on execute as CGI completely breaks the site. No theme, can’t login. admin page say “Not Found”. It is as if turning that on just breaks the database. But only on sites with hefty modules enabled.

I just noticed that the error log is reporting the IP ( of my router. I am running in virtualbox behind a router, could that possibly be throwing it off somehow?

“[Mon Feb 27 12:30:28 2012] [error] [client] script not found or unable to stat: /home/cgfix/domains/dru6.cgfix.com/cgi-bin/sites, referer: http://mydomain.com/