error with restoring from file upload (rights issue?)


One of my clients tried to restore his backup he made several hours before. He used the option download in browser and restore by file upload.

He get this error:

Restore failed : Failed to open /home/dom00502/virtualmin-backup/backup.tgz : No such file or directory

This error seems right, because there is no directory ‘virtualmin-backup’ when i looked at te virtualserver directory’s.

When i tried with his administrator account i got the same error, so he did nothing wrong.
But when i tried to restore with the super-admin account there is no problem at al. But also there is no ‘virtualmin-backup’ directory made, so the initial error seems al little strange now

Maybe it’s a rights problem, but i can’t figure out where to search for.

Please can someone help me to figure this out?


A bug along those lines was recently fixed, but it’s just different enough that maybe we ought to have Jamie take a peek at that.

I’m going to forward your post to him and verify that this was indeed fixed – if that’s the case the new Virtualmin version that contains this fix may be coming out as soon as today.



A few quick questions –

Which Virtualmin version is this, and is it Pro or GPL?

And is this the Virtual Server owner? Or a reseller? (A reseller is only available in Virtualmin Pro)



Hi Eric,

It’s Virtualmin GPL and he is a virtual server owner.

Joe is going to be pushing out a new release hopefully today – whenever you have a chance to try that new release, can you let us know if that resolves your issue?

If not, would it be possible for us to log into your server so that we can troubleshoot the issue?


Hi Eric,

Did update Virtualmin to the newest release and that did the trick. Many thank’s