Error when using Install Scripts


I am having some trouble with the Install Scripts feature. When I specify a username with an uppercase character for a script that requires a username and password, I get this error:

Failed to install script : Invalid login for script - only letters, numbers and the characters . - _ may be used

which seems a little illogical, seeing as uppercase LETTERS should work. Is there a workaround for this?



Which install script is it that you’re trying to install?


It actually happens for any install script that requires a username.

I tried it with WordPress and Django and the same error pops up.

Does it have something to do with how the function scriptname_passmode() is handled by the server?

On an unrelated note, is there any way when writing an install script in Perl to get a FTP login? E.g. &mysql_user($d) gets a MySQL login username, is there an equivalent for FTP logins?

Thank you very much for your help.

Okay, I did some testing – now, I don’t believe WordPress asks for a username/password as part of the installation.

However, Django does, and I was able to reproduce what you were seeing.

I’ll talk to Jamie about that and see if that’s intentional or not :slight_smile:


Okay, it turns out that this is indeed a bug. It will be fixed in Virtualmin 3.88.

Thanks for pointing it out!