Error when changing PHP parameters

Good morning,

I currently have a VPS (Ubuntu 18.04) (I’ve been using it for a couple of months) with 2 Prestashop websites (one is barely used, it’s in catalog mode and has very little load) and another one that is a small online shop in use. Besides this I have 2 Facturascrip webs in the same VPS.

I am trying to optimize my online store according to the recommendations of prestashop and when I put the parameters in

[Date]
date.timezone = UTC

[Session]
session.auto_start = Off

[PHP]
short_open_tag = Off
display_errors = Off

magic_quotes_gpc = off
; Increase this value if you are able to do it
memory_limit = 512M
max_execution_time = 300
max_input_time = 300
upload_max_filesize = 20M
post_max_size = 22M
; Increase this value if you work with products with a lot of combinations
max_input_vars = 20000
allow_url_fopen = on

Services>PHP-FPM Configuration>Edit Configuration Manually

The PHP server goes down, knocking down all 4 websites.

I understand that I’m doing something wrong and it’s probably a silly thing to do, but I can’t imagine what it could be.

First of all thank you very much for your time and attention.

Hi,

Thanks for your feedback.

It might be a bug as well. Have you tried before going to PHP-FPM Configuration completely reloading the page, and doing it, still causes the same issue?

The second work-around, would be is to try to change PHP options using CLI, like this:

virtualmin modify-php-ini --domain DOMAIN.com --ini-name post_max_size --ini-value 16M --ini-name upload_max_filesize --ini-value 8M

Please give those a try and let us know how it works for you?

First of all, thank you very much for your time and interest.

Sorry, but I don’t know if I understand correctly what you mean by reloading the page. The server works correctly until I introduce the exposed modifications and then the PHP services fall down, even if I try to start them it gives the following error:

Starting service php7.2-fpm …
Starting php7.2-fpm (via systemctl): php7.2-fpm.serviceJob for php7.2-fpm.service failed because the control process exited with error code.
See “systemctl status php7.2-fpm.service” and “journalctl -xe” for details.
failed!

– Unit php7.2-fpm.service has begun starting up.
Mar 12 13:38:14 php-fpm7.2[20149]: [12-Mar-2020 13:38:14] ERROR: [/etc/php/7.2/fpm/pool.d/158024615228293.conf:21] unknown entry ‘date.timezone’
Mar 12 13:38:14 php-fpm7.2[20149]: [12-Mar-2020 13:38:14] ERROR: Unable to include /etc/php/7.2/fpm/pool.d/158024615228293.conf from /etc/php/7.2/fpm/php-fpm.conf at line 21
Mar 12 13:38:14 php-fpm7.2[20149]: [12-Mar-2020 13:38:14] ERROR: failed to load configuration file ‘/etc/php/7.2/fpm/php-fpm.conf’
Mar 12 13:38:14 vps777835 php-fpm7.2[20149]: [12-Mar-2020 13:38:14] ERROR: FPM initialization failed
Mar 12 13:38:14 vps777835 systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=78/n/a
Mar 12 13:38:14 vps777835 systemd[1]: php7.2-fpm.service: Failed with result ‘exit-code’.
Mar 12 13:38:14 vps777835 systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager.
– Subject: Unit php7.2-fpm.service has failed
– Defined-By: systemd
– Support: http://www.ubuntu.com/support

– Unit php7.2-fpm.service has failed.

– The result is RESULT.
and if I restart the server still doesn’t work. I am not modifying PHP.ini, I am modifying : /etc/php/7.2/fpm/pool.d/15805228293.conf

I’m trying to modify only the shop’s website.

As for modifying by CLI, I can try, but I’m a bit afraid I won’t be able to go back in case of an error like this.

I seem to have found the problem.

I added php_admin_value [value]

and I haven’t left any spaces or notes (notes of the type [Date]. Yesterday I tried this, but when I left blank lines (I guess that would be it) I still got it wrong.

Thanks again for everything. :slight_smile:

You shouldn’t be afraid of using CLI as it will do the things the right way for you. I have taken a closer look at your issue, and it appears that you’re not using correct syntax. You can not put raw values, as they should be used as part of php_value, like:

php_value[post_max_size] = 64M

Thanks a lot my friend for your time and answers, I finally managed to solve it.