Error trying to restore a domain to a new server

I am trying to restore a domain to a new Virtualmin Pro server 3.56 from another Virtualmin Pro 3.58 server that I have done the backup on but keep getting the error:-
Re-creating virtual server
… the server template specified in the backup does not exist

I have created the template but it still not accept the backup.

I have done the backup via SSH and to a local file but both give the same error.

Any clues ?



The problem here is that in order for Virtualmin to re-create the domain on the new system, it needs the custom template that it was originally created with. Templates are identified in the system with an ID number, and if no template with the same ID exists on the target system, you will get that error message (even if one with the same name exists).

The quick fix is as follows :

  1. On the source system, look in the /etc/webmin/virtual-server/templates directory to see the ID of your custom template (assuming you have only one).

  2. On the target system, rename the template file in that same directory to have the same ID as the source system.

  3. Re-try your restore.

Thanks Jamie, This fixed that issue.