Error - Perl execution failed

Error - Perl execution failed

Failed to open /home/user/.usermin/changepass/config for writing : Bad file descriptor at line 1311.


Santa’s not around? Santa must be full and fall asleep… How about Elves? Help?.. Please :slight_smile:

I mean Deer will do… I s Santa’s Deer around?

hehe… Merry Christmas again everyone… Where is Joe, I wish Joe is around…

A merry Christmas to Joe and Virtualmin team… And of course their families too… And Happy New Year…

Howdy Trendy,

I fear I’ve been too Christmas’ed up to be much help. I’m back to work now, though. :wink:

Are you running the latest version of Virtualmin and Webmin? If so, it’s a bug. I’ll ask Jamie to chime in on this thread.

For future reference: If you’re running the latest stable Virtualmin and Webmin version and seeing Perl errors, it’s a bug. Always. File it in the bug tracker and it will get fixed quick (Jamie’s super human about stuff like this).

Yes, this looks like a bug. Could you let me know which version of Virtualmin you have there, and if it is the GPL or Pro release?


I am getting the same error

HTTP/1.0 500 Perl execution failed Server: MiniServ/0.01 Date: Thu, 3 Jan 2008 01:48:26 GMT Content-type: text/html Connection: close
Error - Perl execution failed
Not an ARRAY reference at …/ line 299.

Operating system Debian Linux 4.0
Webmin version 1.380
Virtualmin version 3.50 (Pro)

Operating system Debian Linux 4.0
Perl version 5.008008
Path to Perl /usr/bin/perl
Postfix version 2.3.8
Mail injection command /usr/lib/sendmail -t
BIND version 9.3.4
Apache version 2.2.3
PHP version 4, 5
Webalizer version 2.01-10
Logrotate version 3.7.1
MySQL version 5.0.32
ProFTPd version 1.30
SpamAssasssin version 3.1.7-deb
ClamAV version 0.90.1

Happy New Year

A bug was filed on this :

And I found the underlying cause, and posted a work-around to the bug. Also, the fix will be included in the 3.51 release of Virtualmin.

Thnks for the prompt reply Jamie

I do not have the folder described in the fix, where can I find the file?


If you are on a Debian or Ubuntu system, it will be at /usr/share/webmin instead.

Thanks Jamie

Worked perfectly


Webmin/Virtualmin/Usermin live in /usr/share instead of /usr/libexec on Debian/Ubuntu systems. So, the path would be /usr/share/webmin/virtual-server/

Mmm, that sounds like a problem worthy of a bug report :slight_smile:

I’m not sure what exactly might cause that, but I bet Jamie would!

You can file a report using the Bugs and Issues link below.


Okay I kinda solved it but I worried it might affect anything… I kinda commented the line 299 on that is causing the problem.

#local %sel = ref($value) ? ( map { $_, 1 } @$value ) : ( $value, 1 );

will this cause anything? Santa? Elves? Deer?

I missed Joe… He knows everything… Almost everything and he is the best forum moderator EVER…

Oh, and don’t comment out that %sel line - it will break all other drop-down menus in Webmin! It is better to find the line that is really causing the problem. You can see this by going to Webmin -> Webmin Configuration -> Advanced Options, and changing ‘Show stack trace for error messages?’ to ‘Yes’.

I’ve got the same problem and unfortunatly link for the solution is out !
Can someone give information to solve this proble ?


Sorry, i find the solution here :