error /oracle dir. is not exist

I m using webmin 1.420, virtualmin 3.63.gpl and sun solaris 10 OS. We are adding the module of virtualmin-oracle.wbm.gz from webmin module. it has been added properly. but when i m filling the all data base information then click the save then show the some error
“Oracle configuration problem detected : Directory /oracle to create new database files in does not exist. You may need to adjust the module configuration.”

My oracle home directory is /orasure/app/oracle/10g

So please solve this problem…


Well, you’re using an older version of Webmin and Virtualmin – those versions were released back in 2008. It’s hard to tell, but it’s quite possible you’re stumbling onto bugs that have been fixed since then.

You may want to consider upgrading to a recent version (especially since versions before 3.70 have a security hole in them).

Regarding the Oracle module though – are you saying that you went into the Module Configuration, set the Oracle home directory to “/orasure/app/oracle/10g”, and it still is trying to save to /oracle?

If you’ve tried changing that option in the Oracle Module Config section, my recommendation is to try upgrading both Webmin and Virtualmin to more recent versions.

If you haven’t tried changing those parameters – give that a shot and see if that helps :slight_smile: