Error by installing Virtualmin on Centos 8: No matching repo to modify: PowerTools

Hi all,
After many problems with postfix not starting because the port 25 was, mysteriously, in use by nothing, I decided to do a fresh install. The OS and the webmin was installed automatically by my hosting provider.
After the installation, I tried to install the default package of virtualmin. This is what I get every time(I made more than 5 fresh installs with the same results):

▣▣□ Phase 2 of 3: Installation

Installing EPEL release package [ :heavy_check_mark: ]
Enabling PowerTools package repository [ERROR] Failed with error: 1
[ ✘ ]

[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
warning: virtualmin-release-latest.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 60d62a6b: NOKEY
Installing virtualmin-release package: Success.
[2020-12-08 03:52:58 CET] [DEBUG] Phase 2 of 3: Installation
Spin pid is: 12896
Last metadata expiration check: 0:00:06 ago on Tue 08 Dec 2020 03:52:52 AM CET.
Package epel-release-8-9.el8.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Installing EPEL release package: Success.
Spin pid is: 12990
Error: No matching repo to modify: PowerTools.
Enabling PowerTools package repository: [2020-12-08 03:53:00 CET] [ERROR] Failed with error: 1
[2020-12-08 03:53:00 CET] [ERROR] Something went wrong. Exiting.
[2020-12-08 03:53:00 CET] [ERROR] The last few log entries were:

I have also tried to enable the PowerTools with no success:
dnf config-manager --set-enabled PowerTools
dnf install -y epel-release
etc…

If you have any idea of what is happening it would be amazing.
Thank you.

Operating system: CentOS Linux
OS version: 8.3.2011

Hello @TheMGuy and welcome to the community.

It is necessary to install Virtualmin (best done via automated install - see below) on a fresh server - i.e. a server with a freshly installed OS - so if you are installing Virtualmin five times on upon a previously failed installation then you will not make much progress.

Why don’t you try Virtualmin automated install from the official documentation at https://www.virtualmin.com/documentation/installation/automated on a freshly installed server? The previous approach of your provider installing webmin and then you adding Virtualmin is not working.

In summary: get a fresh OS from your service provider; then install Virtualmin directly via automated install procedure.

Hi,

I remember making a patch for CentOS 8 to also work with PowerTools repo when spelled lowercase. Try dev version of install script and see if it works for you?

Just ran into this today with CentOS Linux 8 (2011). Fresh vagrant install with ‘centos/8’.

Is it related to repo changes made in preparation for CentOS Stream?

I’m using the script recommended at https://www.virtualmin.com/download i.e.
http://software.virtualmin.com/gpl/scripts/install.sh

@Ilia can confirm the dev version of install allows installer to run successfully for me, thanks.

Thanks, good to know. @Joe - could you push it upstream?

Hi, thank you for the reply and sorry for the late response. I’ve made 5 fresh OS installs, not only Virtualmin. I will try it right now.

Hi, thanks for the reply. I will try it right away.

Hi,
Can confirm as well, the dev version worked like a charm.

Thank you guys.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.