Error 403 Virtualmin


It is my first time with a virtual server, I have a VPS with Virtualmin on Debian 8.
I have configured a domain that I own to be able to host it in this VPS (the domain is, I have the dns configured but when accessing it it shows me the following error:
You don’t have permission to access this resource.
Visiting different queries that I have found through the forum I have disabled the FirewallD and I have configured the linux firewall to allow port 80, I have checked that the permissions of the folders are 755, but still I cannot access.

This error appears in the log:
[Sun Apr 26 17: 38: 36.903044 2020] [core: error] [pid 22791] (13) Permission denied: [client] AH00035: access to / denied (filesystem path ‘/ home / lockesoft’) because search permissions are missing on a component of the path
[Sun Apr 26 17: 38: 37.056923 2020] [core: error] [pid 22791] (13) Permission denied: [client] AH00035: access to /favicon.ico denied (filesystem path '/ home / lockesoft ') because search permissions are missing on a component of the path, referer:

If you want to access the webpanel, then you should attach “:10000” for virtualmin and “:20000” for usermin.
That has nothing to do with the firewall, so its fine to re-enable that. :slight_smile:


thanks for your answer, what I want is that when I access it shows me the html files that I have in the public_html folder.

I can access the virtualmin control panel, but if I try to view the index.html file that I have uploaded it shows me the error.

Thank you

For that you would need to set that setting either in the .htaccess file (create one and upload it) or directly in the vhost file.

Thanks, I have never created an htaccess, can you guide me more or less, or what do I have to modify in the vhost?

I have searched the internet for information about htacces but it is not entirely clear to me, in the end I found an htacces generator and it has generated the following code:
// Rewrite to www
Options + FollowSymLinks
RewriteEngine on
RewriteCond% {HTTP_HOST} ^ [nc]
RewriteRule ^ (. *) $ Http://$1 [r = 301, nc]
I have uploaded it to the public_html folder along with the index.html but it still doesn’t work

If you want to enable the directory listening, you need to put: Options +Indexes into the .htaccess file.
It is possible, that you need to edit the vhost file so that it wont use index.html or similar as the index.
If I recall it correctly, you can archive that with: DirectoryIndex disabled in the .htaccess file.

Depending on what you want to archive, you might need to take a look at:

IndexOptions FancyIndexing

I have been testing what you have told me, apparently everything is correct, since I did not know where to continue I have decided to eliminate the vps and start from scratch, I have done so many tests that perhaps I have touched something that should not.

When creating the vps I have noticed that it shows me several errors that the first time I create it I do not notice, I copy the result of the creation of the vps:
Creating administration group lockesoft …
… donate
Creating administration user lockesoft …
… donate

Creating aliases for administration user …
… donate

Adding administration user to groups …
… donate

Creating home directory …
… donate

Creating mailbox for administration user …
… donate

Adding new DNS zone …
… donate

Adding to email domains list …
… donate

Adding default mail aliases …
… donate

Adding new virtual website …
… donate

Adding webserver user www-data to server’s group …
… donate

Performing other Apache configuration …
… configuration failed: Failed to copy /etc/php5/cgi/php.ini to /home/lockesoft/etc/php5/php.ini: cp: failed to access â € ˜ / home / lockesoft / etc / php5 / php .iniâ € ™: Permission denied

Setting up scheduled Webalizer reporting …
… Webalizer reporting failed! : Failed to open /home/lockesoft/public_html/stats/.htaccess.webmintmp.15927: Permission denied at …/ line 1495, line 1.

Setting up log file rotation …
… Log file rotation failed! : … the log file /var/log/virtualmin/lockesoft.ovh_access_log is already being rotated at …/ line 1495.

Creating MySQL login …
… donate

Creating MySQL database lockesoft …
… donate

Setting up spam filtering …
… donate

Setting up virus filtering …
… donate

Adding DAV directives to website configuration …
… DAV Login failed! : virtualmin-dav :: feature_setup failed: Failed to open /home/lockesoft/etc/dav.digest.passwd: Permission denied at …/ line 1495, line 1.

Creating Webmin user …
… donate

Re-starting DNS server …
… donate

Applying web server configuration …
… donate

Re-loading Webmin …
… donate

Saving server details …
… donate

Its seems that the system doesnt have permissions to some necessary folders.
Did you change anything at the folder permissions?

1 Like

No, I have not changed any of the permissions on the folders

These are the permissions it shows me in / etc / php5 / cgi /:

drwxr-xr-x 2 root root 4096 Apr 22 10:33 conf.d
-rwxrwxr-x 1 root root 72664 Jan 5 2018 php.ini

I think the problem is at the moment when you try to create the folders, because the file you want to copy does have access.

In the end I found the solution, since it seemed that it was an error when creating the folder, disable the apache server of the vps, and before I add it again, create the folders with the corresponding permissions.

I reinstalled the apache server and it worked !!

Thank you very much for the patience and time you have dedicated to me !!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.