Enabling SSL on virtual host breaks HTTP site

OS type and version Ubuntu 20.04.6
Webmin version 2.101
Virtualmin version 7.8.2
Related packages Apache 2.4.41

I had an existing virtual host website running on http. I went to Edit Virtual Server in Virtualmin. Then ticked the checkbox Apache SSL website enabled. This enabled the website to be reachable at https. However, the http website then served a different website on the same server. By looking in Webmin at Servers > Apache webserver identified that Virtualmin had changed the .conf file for the domain in /etc/apache2/sites-available to * from the IP address. On manually editing the .conf file to change the * back to the IP address the http site worked again and served the correct site (as was the https site). It seems to me this is a bug in Virtualmin when enabling the SSL website on an existing http website.

Not sure where it is but there is an option to redirect all traffic to the http version. It might be a good time for the software to ask about that?

Redirect to the https version.
Server Configuration, Website Options, Redirect all requests to SSL site Yes/No

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.