Enabling Server as Backup Mail Server Removed root's Functionality in Virtualmin

OS type and version Rocky 8.7
Webmin version 2.001
Virtualmin version 7.3 Pro
Related packages Postfix, Webmin

This is more of a report than a request. I won’t necessarily call it a “bug report” because the configuration is unusual. But it’s probably something you’d want to know about.


server1.example.net hosts Web services for example.com, but not mail.
server1.example.com host mail services for example.com, but not Web.

In anticipation of a planned maintenance outage on the mail server, server1.example.com, I enabled server1.example.net as a backup mail server using instructions found here.

That seems to have worked as far as holding the mail was concerned.


When I logged back into Virtualmin as root this morning, all functionality was missing. I didn’t take a screenshot because I hadn’t had my second cup of coffee and wasn’t thinking clearly, but all that was available on the Virtualmin side was “System Statistics” (which worked).

The virtual servers were not there.

The dropdown box was not there.

Nothing was there except “System Statistics” and the logout button.

The Webmin side of things looked normal; so I used that to restore the previous Postfix configuration. I’d made a backup of the most-recent Webmin configuration backup before setting up the backup mail server, not because I am wise, but because deep down I consider computers to be more like mistresses than wives. They’re a lot of fun, but not to be trusted.

Accordingly, I’d backed up the Webmin configuration backup so it wouldn’t be overwritten by a new backup on the next backup. Which suggests a possible improvement: It would be nice if the Webmin configuration backup supported versioning. But I digress.

In any case, restoring the Postfix configuration (essentially undoing the server’s role as a backup mail server) restored full Virtualmin functionality.

I then went into server1.example.com, the server providing mail services, and disabled server1.example.net as a backup mail server.


I’m pretty confident the backup mail server configuration was not the cause of that problem. But, I don’t know what is.

This sounds like a new one, actually…we’ve had problems in the past that allowed the root user to assign ownership of a domain to themselves (instead of a new user), which would take away all privileges except those provided to the domain, but you don’t have any domains, so it’s not that (and I’m pretty sure all the paths to get to that behavior have been closed).

And, we’ve had a file locking problem that could lead to Virtualmin domains being listed as numbers, but I’m pretty sure all paths to that bug have been fixed, too.

I’m not sure how we’d end up with no Virtualmin stuff visible. I’ll have to try running through the secondary mail server guide to see if anything jumps out at me as something that could cause the root user ACL to get messed up like this (as I think that’s what happened, but could be something else).

It’s unclear to me why a change to the mail configuration would cause everything except “System Statistics” to be gone in Virtualmin. But there were no other system-wide changes during that period, and undoing the change by restoring the configuration from backup did restore functionality.

I should point out that the email addresses already existed on server1.example.net prior to assigning it as a backup mail server. It was created from a cPanel backup that excluded the mail, but did include the mail configuration. Perhaps that had something to do with the problem.


It looks to be more of a browser cache problem that wasn’t loaded properly.
I would re-create the backup configuration just see if it would happen again.



Thank you, but I don’t think so. I tried to log in using another browser on another computer specifically to rule that out. That computer also happened to be behind a VPN at the time. The display (or lack of same) was the same.

I may try it again anyway just for the sake of having the backup mail server enabled. But I do those kinds of things at night.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.