Enable ClamAV Server button is missing / clamd@scan.service not present in boot and shutdown services


I noticed that the clamd@scan.service and clamav-freshclam.service are missing from Bootup and Shutdown services.

If I look for the clamd service, it seems that it is running:

[root@virtualmin log]# ps auxw | grep clamd@scan.service
root 20636 0.0 0.0 112712 972 pts/0 S+ 23:32 0:00 grep --color=auto clamd@scan.service

The Run ClamAV Server button is missing from Email Settings/Spam and Virus Scanning. Only Enable/Disable SpamAssassin Server button is present.

Can you please advise on how to install and configure clamd on the server?

Thank you

CentOs 7
Virtualmin 6.09

1 Like

Did you do a --minimal install? That is explicitly choosing to leave out ClamAV, as it’s the most resource-intensive thing in a Virtualmin system.

If you install the ClamAV packages from EPEL, the option to use it should appear. You may need to run:

# virtualmin config-system --include ClamAV

Which will do whatever preliminary stuff the installer does for ClamAV (I don’t remember what that’d be off-hand.

But, presumably if you used the --minimal option, you wanted a low-resource version of Virtualmin, and running ClamAV (in daemon form or on-demand) blows that idea away completely. It needs nearly a GB of RAM just to start up.

1 Like

Oh, and here’s the ClamAV packages we normally install:

      <packagereq type="default">clamav</packagereq>
      <packagereq type="default">clamav-scanner-systemd</packagereq>
      <packagereq type="default">clamav-server</packagereq>
      <packagereq type="default">clamav-server-systemd</packagereq>

Hi, Joe,

I did a standard install, that’s why I don’t understand why ClamAV is missing.

Please confirm that all I have to do is to run “virtualmin config-system --include ClamAV” and that no other packages installation or configuration is required.

Thank you

That’s not what I said. I said install the packages (using yum), and then run that command. That command can’t do anything useful if the packages are not installed, it just configures things, it does not install packages.

The only other way you’d end up without ClamAV installed in a full install would be if your yum configuration doesn’t install default packages from yum groups. But, I think there would have been an error during the configuration stage or install, if that were the case.

Hi, Joe,

I installed the required packages and I run “systemctl start clamd@scan” to start the service.

I then try to enable at start-up clamd@scan.service (from System/Bootup and Shutdown) and I get the following message:

"Enabling service clamd@scan.service at boot time.

Systemd service clamd@scan.service cannot be created unless a command is given"

In System/Bootup and Shutdown I see that clamd@scan.service is “Running now” but “Start on boot” is not active.

Can you please advise?

Thank you for helping

I run “systemctl enable clamd@scan” and now the service starts at boot.

Please advise if I should check the “Local server scanner” instead of the “Standalone scanner”.

Is that any way to check if all works ok and the emails are getting scanned by clamav?

Thank you

Local server scanner uses clamdscan. The next version will have clearer language for those options.

Hi there,
thanks for the info and sorry for hijacking the thread but is there a difference of the clamav installation via Virtualmin if CentOS itself is installed from a minimal installation image, as I ended up with a same situation and problem as @cipandales after running the installation script with standard settings? (my VPS provider has CentOS 7 --minimal listed on the OS installation wizard)
Thank you in advance

I don’t think so. yum should have resolved any dependencies needed to make it work.

But, it’s possible your host configured yum to leave off default packages from yum groups as part of the minimal install. I don’t think they should do that, but it’s the only reason I can think of for it to happen. That’s the group_package_types option in yum.conf, and might be set some other way as well. I don’t really know as I’ve never used it, I just know it exists.

I can’t really tell you what happened without seeing the related errors from during the installation. What’s in the virtualmin-install.log when you search for clam? There have to be errors, unless you installed Virtualmin with the --minimal flag, as it would have tried to install clamav packages, and would have tried to configure it and should have produced an error during the config step.

thanks for the fast response Joe
the only option I used during install was that I chose nginx instead of apache --bundle LEMP. I’ve searched my virtualmin-install.log and I have quoted some parts of the file that state installation type and any reference about clamav

[2019-12-29 14:03:01 EST] [INFO] Started installation log in /root/virtualmin-install.log
[2019-12-29 14:03:01 EST] [DEBUG] Phase 1 of 3: Setup
[2019-12-29 14:03:01 EST] [DEBUG] Install mode: full
[2019-12-29 14:03:01 EST] [DEBUG] Product: Virtualmin GPL
[2019-12-29 14:03:01 EST] [DEBUG] install.sh version: 6.0.20
Spin pid is: 9472
There is no installed groups file.
Maybe run: yum groups mark convert (see man yum)
Updating yum Groups: Success.
Spin pid is: 9512
2019-12-29 14:03:01 URL:https://software.virtualmin.com/vm/6/gpl/centos/7/x86_64/virtualmin-release-latest.noarch.rpm [14112/14112] -> "virtualmin-release-latest.noarch.rpm" [1]
Downloading virtualmin-release-latest.noarch.rpm: Success.
Spin pid is: 9537
warning: virtualmin-release-latest.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 60d62a6b: NOKEY
Installing virtualmin-release package: Success.

[2019/12/29 14:09:17] [INFO] - Configuring ClamAV
[2019/12/29 14:09:35] [INFO] - Code: 0 Result: ClamAV update process started at Sun Dec 29 14:09:17 2019
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.101.5 Recommended version: 0.102.1
DON'T PANIC! Read https://www.clamav.net/documents/upgrading-clamav
Downloading main.cvd [100%]
main.cvd updated (version: 59, sigs: 4564902, f-level: 60, builder: sigmgr)
Downloading daily.cvd [100%]
daily.cvd updated (version: 25678, sigs: 2082745, f-level: 63, builder: raynman)
Downloading bytecode.cvd [100%]
bytecode.cvd updated (version: 331, sigs: 94, f-level: 63, builder: anvilleg)
Database updated (6647741 signatures) from database.clamav.net (IP:

has following entries during that install
Dec 29 14:05:15 Installed: clamav-filesystem-0.101.5-1.el7.noarch
Dec 29 14:05:16 Installed: clamav-update-0.101.5-1.el7.x86_64
Dec 29 14:05:16 Installed: clamav-lib-0.101.5-1.el7.x86_64
Dec 29 14:07:41 Installed: clamav-0.101.5-1.el7.x86_64

@alphakapa You definitely don’t have the same problem as OP. ClamAV is obviously installed.

Oh, but clamav-scanner-systemd is missing from that yum log. I’m not sure what to make of that.

as @cipandales noted his clamd service is running. in my installation on the boot and shudown services I only have [clamav-freshclam.service] but not the clamd@scan.service and I don’t have the ClamAV server button as well!

Yeah, that’s provided by the clamd-scanner-systemd package on CentOS 7. I wonder why it isn’t installed for either of you?

What happens with this:

# yum search clamav-scanner-systemd

Damn it. They’ve removed those packages upstream. The Fedora/EPEL packages of ClamAV are a nightmare…they change structure all the time.

But, the necessary service is provided by the clamd package now. So, I guess I need to update the yum groups to use it instead.

]# yum search clamav-scanner-systemd
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

So this could be an issue that affects all new installations?

Yes. Install clamd.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.