Emails sent no problem, but not receive from external

Webmin version 1.979
Virtualmin version 6.16
Operating system Ubuntu Linux 18.04.5

Hey everyone,

I need some help help here with email issues. The problem is no email is received if sent from an external service, for example outlook or gmail, but if I send an email to myself internally, the email is received no problem. There’s no issue sending emails though, to any email addresses. My developer can’t find the issues and it looks like he’s not trying hard to fix the problem. So please, if someone can look into this for me, I’ll be happy to pay for the service or provide step by step instructions is also okay. I will really appreciate your help.
The domain name is I read the other forums about the issue but I couldn’t find a fix.

Hello Koneks,

I have sent you a DM.


You will need to set up an MX record for your domain.

Thank for your reply.
This is exactly what I read from other forums, but my developer said we only have to setup MX record if we were using a third party mail service like outlook or gmail. If I knew what to add in the “Assign Server” field, I would try and see if it works.

Regardless of whether you are using a third party mail service or not, an MX record is required if you want to receive mail. And other records as well if you don’t want your mail to end up in spam.

Go into Server/Postfix/General and see if you have whole domain to receive email.

If that’s actually what your developer told you then you had better find another.


This developer has done many projects for me and he has been very helpful in the 3 years I have known him. This is the first time he is stuck on an issue that seem he can’t find the solution to fix.

Thanks for your message.
I have selected Whole Domain, that’s after I read your message. The issue is still there.
My developer has setup MX record, and still not receiving emails.

This is the error log received when I tried to send a message from an outlook email.
Diagnostic information for administrators:

Generating server: SY4P282MB1177.AUSP282.PROD.OUTLOOK.COM
Total retry attempts: 37

Remote Server returned ‘550 5.4.300 Message expired → 451 4.3.5 Recipient address rejected: Server configuration problem’

Original message headers:

ARC-Seal: i=1; a=rsa-sha256; s=arcselector9901; d=microsoft.; cv=none;


ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed;;





ARC-Authentication-Results: i=1; mx.microsof---- 1; spf=pass

smtp.mailfrom=; dmarc=pass action=none header.from=;

dkim=pass; arc=none

Received: from SY4P282MB1689.AUSP282.(2603:10c6:10:c3::16) by

SY4P282MB1177.AUSP282.(2603:10c6:10:b2::15) with Microsoft

SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id

15.20.4394.15; Fri, 6 Aug 2021 01:07:11 +0000

([fe80::11c2:f92a:407e:513%9]) with mapi id 15.20.4373.028; Fri, 6 Aug 2021

01:07:11 +0000

MX records are set, using it shows you pointing to a IP thats registered to Inmotion Hosting. Is that correct?

Thank you to everyone with the help provided.
I hired another developer to fix the problem and he as well couldn’t find the issues. I decided to switch to Inmotion hosting for email server only. Still had the same issue. I called the domain provider (CD), for the 4th time, and they finally found out that they didn’t sync the domain name properly, and they fixed it. Now email is working all fine.

Thanks again for your support everyone.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.