Emails. Nothing comes out or goes in from the start

OS type and version: CentOS Linux 8.4.2105
Webmin version: 1.981
Virtualmin version: 6.17
Related products version: ?

I am on a live server at home. My problem is with emails. Nothing comes out or goes in from the start. Can you help me with small commands that return relevant information that then lets you know more? I’m translating this message from French to English using Google Translate, good luck.

Hi, unfortunately this issue can be very wide.

  1. Is your internet adsl/broadband and is your router configured for static ip or dhcp by ISP

  2. Is your server online and can access the internet. Some ISP’s will block certain ports. Do you also have a local firewall?

The IP address has never changed for a year, but it will be a dynamic address. IP address: My system hostname

My server is online and my ISP has told me that no port is closed on their end.
My Firewall version [ConfigServer Security & Firewall 14.11

TCP_IN = 20,21,22,25,53,80,110,143,443,465,587,993,995,2525,9312,10000,20000
TCP_OUT = 20,21,22,25,53,80,110,113,443,465,587,993,995,2525,9312,10000,20000


1 Like

hi I’m hosting from home too, check ports for your server if you’re not DMZ.

CSF is configured to enable ports but is your internet router also enabled to pass through these ports out/in?

Connecting to
10/28/2021 1:02:00 PM Connection attempt #1 - Unable to connect after 15 seconds. [15.04 sec]

Did it used to work? Have you changed adsl/broadband since then?


  • Enable SPI: (X),
  • Enable anti-spoof checking: (_),
  • Enable DMZ: (X),
  • Adresse IP DMZ (, = my server

Ports to Open

  • Name, [my PC :stuck_out_tongue: ]
    TCP 16000, Schedule Always, IP Address
    UDP 16000, Inbound Filter Allow All

  • Name op.spip.ca1 [server]
    TCP 1-15999, Schedule Always, IP Address
    UDP 1-15999, Inbound Filter Allow All

  • Name op.spip.ca2 [server]
    TCP 16001-65535, Schedule Always, IP Address
    UDP 16001-65535, Inbound Filter Allow All

Can you access the virtualmin panel externally? Has this setup worked before or is it a new setup? Instead of adding a port range, try to use individual ports. Specific ports that needs open. I have had a few challenges in the past where port range hasn’t worked, for some odd reason individual ports were needed but probably just my crappy home router. Is that a physical machine or vm/virtualbox, if the latter I assume network has been bridged? Host OS got any firewall?

I have always had access to webmin $ virtualmin externally, websites also work fine, except for mail which I never did. This is a new clean configuration on a single physical machine with the internal address What do you mean by “The host operating system has a firewall?”, The op.spip system .ca has only ConfigServer Security & Firewall has internal IP address Another personal machine has Windows and it is configured by default, only with defendant Windows. Later, I’ll follow your recommendation about “try to use individual ports.”.

I reinstalled postfix, something new! when accessing usermin, I have the following message “An error occurred listing mail in this folder: 0 Failed to IPv6 connect to localhost: 143: Connection refused


That reference was if server was virtual inside another host. So ignore that. I don’t know if your ISP has allocated both ipv4 and ipv6. Maybe try to disable ipv6 in virtualmin/postfix so it uses ipv4 only.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.