Email won't work after swecond server

SYSTEM INFORMATION
OS type and version AlmaLinux 10.2
Virtualmin version 8.2 Pro

After the second domain was finally working, I tried to connect to send mail to the email boxes as well as sending from the new email addresses, but neither worked.
Sending from the email address presents (within Thunderbird) a message like “Could not connect to the SMTP-server”. Sending a message to the email account produces this error: “Recipient address rejected. User unknown in virtual mailbox table.”

I know for sure that the user is there, at least he is in the list of users for that domain, and from what I see, email is enabled.
And now I found out, that the email of the other domain has stopped working as well, it’s the same messages that I get in response to sending from or to the mailbox.
I checked if postfix and dovecot are running, and both are reported as being active and enabled. Is there any other service I would have to check? Or did I mess up something?

The only thing I did at around the time when this issue started was adding TLSA records to the DNS - which I later removed again. I just needed to check if Virtualmin is actually connected to Cloudflare (which it is). If that could have caused such problems, I probably need to wait a few more hours, until DNS caches are being fully updated. But if this cannot affect email services, I would be clad if anyone could help me pinpoint the cause of the problem.
I am stuck here.

When migrating between old server and new, it can help if we use the hostname of each vps as incoming and outgoing server in the mail client.

How about Usermin. Are you able to send / receive mail with it?

“Stopped working” is too generic a term. Can not send / Can not receive is more informative.

That would be wise.