Email sending and receiving within Thunderbird after setting up second server doesn't work

SYSTEM INFORMATION
OS type and version AlmaLinux 10.2
Virtualmin version 8.2 Pro

After the second domain was finally working, I tried to connect to send mail to the email boxes as well as sending from the new email addresses, but neither worked.
Sending from the email address presents (within Thunderbird) a message like “Could not connect to the SMTP-server”. Sending a message to the email account produces this error: “Recipient address rejected. User unknown in virtual mailbox table.”

I know for sure that the user is there, at least he is in the list of users for that domain, and from what I see, email is enabled.
And now I found out, that the email of the other domain has stopped working as well, it’s the same messages that I get in response to sending from or to the mailbox.
I checked if postfix and dovecot are running, and both are reported as being active and enabled. Is there any other service I would have to check? Or did I mess up something?

The only thing I did at around the time when this issue started was adding TLSA records to the DNS - which I later removed again. I just needed to check if Virtualmin is actually connected to Cloudflare (which it is). If that could have caused such problems, I probably need to wait a few more hours, until DNS caches are being fully updated. But if this cannot affect email services, I would be clad if anyone could help me pinpoint the cause of the problem.
I am stuck here.

When migrating between old server and new, it can help if we use the hostname of each vps as incoming and outgoing server in the mail client.

How about Usermin. Are you able to send / receive mail with it?

“Stopped working” is too generic a term. Can not send / Can not receive is more informative.

That would be wise.

Hi, thank you for your reply. I am not sure what you mean by “Usermin”, but I guess it’s the “Edit user” section in Virtualmin. There is a button “Email all mailboxes”, which I tried now, and surprisingly, that worked. I could receive the Email within Thunderbird without any error.
I also found an email which I sent yesterday to the other domain’s email address was received there. However, trying to send an email from within Thunderbird to the second domain still leads to the error “Recipient address rejected: User unknown in virtual mailbox table.” An email to the first domain can be sent without error, but it doesn’t appear right away in the mailbox (like the mail from Virtualmin). At least I do not get an error message when sending from within Thunderbird.

I’ll change that. For me it was a total “doesn’t work”, but you are right, it’s not clear enough.
And maybe it’s now that 24 hours have passed, or it was a glitch in Thunderbird: I just wanted to try to change the password for the smtp server, because I wasn’t sure if I had entered the right one, and found that the server was not in the password list (but it was in the list of smtp servers). Hence I first restarted Thunderbird, because I thought that somehow a cache wasn’t handled properly, but since the smtp server wasn’t in the password list, I deleted the smtp server from the account settings list and created a new entry and tried again to send an email, and this time it worked.
So it may have been a Thunderbird issue, maybe it had to do with the DNS entries…

I stumbled over another issue (identity theft) which I had (and have) to take care of, hence a slight delay. I tested now sending emails to the two users who are established on the two different websites/domains: one goes through, the other still sends back the message: Recipient address rejected: User unknown in virtual mailbox table.
The sending of mails seem to work from both users.
Any ideas on this?

I have a suspicion: it seems that the mails to the mailbox are still directed to the old server. I disabled the mailbox and the mail server on the old server for that domain now completely. I hope that will solve the problem. But currently the mail sent to the new server’s user just times out.

Last info, in case someone else has a similar problem: after I had waited long enough, all email functions are there.