Email rejected: postfix header charset=<NULL>

OS type and version Ubuntu Linux 22.04.4
Webmin version 2.111
I’m migrating my working webmin/virtualmin server from Centos 7 to Ubuntu. postfix matches and webin postfix configuration matches on both servers. Configuration checks seem OK. Both postfix files use:
#header_checks = regexp:/etc/postfix/header_checks
I can send emails within the ubuntu server from one account to another internal account. Outgoing email is rejected due to charset set to NULL. I’m guessing ubuntu postfix 3.6.4 might require a different configuration than the centos postfix 2.10.1 but don’t know how the headers get set on either server. Any thoughts on what to check?

Ubuntu server test email:

This is a multi-part message in MIME format.

Content-Type: multipart/alternative; boundary=“altsbound1714059362”
Content-Transfer-Encoding: 7bit

Content-Type: text/plain; charset=
Content-Transfer-Encoding: 7bit

Check all headers

Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit

Sending the same message on the working Centos server shows:

This is a multi-part message in MIME format.

Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit

Check default headers


Solved, or at least a viable workaround. I was using webmin’s postfix server email composer which worked fine on the server I’m migrating from. I just noticed the original server composed in html mode while the new server defaulted to text mode for composing emails. Switching to html mode on the new server sends successfully and sets charset=UTF-8

1 Like

Hmm, that’s probably a little bug-like, but sending mail from Webmin doesn’t happen very often, so I guess it doesn’t get a lot of attention.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.