Email Problem


I was messing around with the dkim, it didnt work so i turned it off. But now I am not able to receive mail.
when I sent a mail consisting of it works.
How can i go about getting it to translate to again???
any help would be gratefully received


Hmm… I haven’t experimented with DKIM myself yet, so I can’t really give a hint about what configuration caveats it might bring. :slight_smile: But I can tell you: don’t feel ashamed, Postfix is a b*tch to configure and understand. :wink:

Normally, “username@domain.tld” is the usual pattern for Vmin email addresses, independent of what the user login naming scheme might be. Having an email address like “user.domain@domain.tld” does not really make sense, although it sure does make sense to have their login name be “user.domain” or, as I do it for reasons of tradition, “user@domain”.

So lemme start with some questions:

What exactly happens when you try to send a mail to “username@yourcomain.tld”? Check /var/log/mail.log for detailed error messages.

What does the email user list of your domain look like? Maybe post a screenshot.

Vmin email users translate to entries in Postfix’ Virtual Domains list (check the Webmin Postfix module). What does that look like?

For each email account, you should find an entry there of the form “Name emailuser@domain.tld maps to userlogin” there, which tells Postfix that the address in question should be locally delivered to the mailbox of the given Linux user. In addition, I think the entry “Name domain.tld maps to domain.tld” is required, even if it looks strange. I didn’t fully understand the documentation there. :wink:

Thank you, it was the virtual domain mapping that has got messed up. it set it up as user.domain instead of I manually tweaked it, now its working.
although any new mail addresses needed to be tweaked as well now. I might do a backup and a reinstall.

You mean after you played with DKIM, Vmin started adding incorrect entries to the virtual domain mapping list, and is still doing so for new email addresses?

Mmh… Can you maybe give a sequence to reproduce this behavior? I might test it then on my experimental VM.

I’ve just created another, and the mapping list is incorrect.
All I did was to enable DKIM and then disable it.
If you’ve got an email address, i can create some login details to the VPS so you can poke around and see what is wrong

Yep okay, I’ll see if I can find something. :slight_smile: You can send it to “admin +AT+ tianet +DOT+ de”. (Sorry for the anti-spam obfuscation ;).)