Email not working via RoundCube (Postfix )

OS type and version: Centos 7
Webmin version: 1.981
Virtualmin version: 6.17
Related products version: Postfix version 2.10.1

Q1: i am using cloudflare, so do i really need bind server? if not do i need to remove or disable that?

Q2. i am using Postfix version 2.10.1 and RoundCube for emailing. but my email doesnt send. i am getting error as bellow.

unauthenticated email from is not accepted due to
550-5.7.26 domain’s DMARC policy. Please contact the administrator of
550-5.7.26 gocloudo . com domain if this was a legitimate mail.

Reporting-MTA: dns; mail. gocloudo. com

how to solve this?

I have enabled Use SASL SMTP authentication? from postfox settings. now when trying to send email not getting any error msg but my email is not seding, i mean i am not getting any emails to my gmail address when sending from my webmail

You should not need to modify the postfix configuration. If you installed using our install script, saslauth should already be configured…anything you change is as likely to break something as fix it, unless you know what you’re doing.

You need to provide maillog entries from when you’re trying to send mail.

1 Like

something like this

Oct 21 22:31:41 we postfix/master[7789]: warning: /usr/libexec/postfix/smtp: bad command startup – throttling
Oct 21 22:32:03 we dovecot: imap-login: Login: user=<info-gocloudo. com>, method=PLAIN, rip=, lip=, mpid=19961, secured, session=<Z4GVyeLO5It/AAAB>
Oct 21 22:32:03 we dovecot: imap(info-gocloudo. com): Logged out in=50 out=533

Something is broken in /etc/postfix/ You’ll need to fix that.

1 Like

here is all the line (active only)

smtp inet n - n - - smtpd -o smtpd_sasl_auth_enable=yes -o smtpd_tls_security_level=may

pickup unix n - n 60 1 pickup
cleanup unix n - n - 0 cleanup
qmgr unix n - n 300 1 qmgr
tlsmgr unix - - n 1000? 1 tlsmgr
rewrite unix - - n - - trivial-rewrite
bounce unix - - n - 0 bounce
defer unix - - n - 0 bounce
trace unix - - n - 0 bounce
verify unix - - n - 1 verify
flush unix n - n 1000? 0 flush
proxymap unix - - n - - proxymap
proxywrite unix - - n - 1 proxymap
smtp unix - - n - - smtp
relay unix - - n - - smtp
showq unix n - n - - showq
error unix - - n - - error
retry unix - - n - - error
discard unix - - n - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - n - - lmtp
anvil unix - - n - 1 anvil
scache unix - - n - 1 scache

submission inet n - n - - smtpd -o smtpd_sasl_auth_enable=yes -o smtpd_tls_security_level=may
smtps inet n - n - - smtpd -o smtpd_sasl_auth_enable=yes -o smtpd_tls_security_level=may -o smtpd_tls_wrappermode=yes

UPDATE: i was trying to send from “Email All Mailboxes” from virtualmin and i got email to my inbox of RoundCube

i think it not sending or reaching from other server such as gmail?

UPDATE: i found this error as well

mod_fcgid: stderr: PHP Warning: require_once(Roundcube/bootstrap.php): failed to open stream: No such file or directory in /home/gocloudo/public_html/mail/program/include/iniset.php on line 63,

I checked my email health with a tool

and found this error

mx DNS Record not foun
dns gocloudo .com SOA Serial Number Format is Invalid
dns gocloudo. com SOA Expire Value out of recommended range

now is it related to emails? and how to solve it?

No you don’t. Just set up the proper DNS records in CloudFlare and you should be good.

You need to add a TXT record specifying your DMARC policy in Cloudflare.

Uninstalling bind will probably cause dependency problems (maybe, I don’t remember if it’s a hard or soft dep)…so, just stop and disable the service and disable it in Features and Plugins.

1 Like

@joe and for readers here.
To have it clear:

If using cloudflare and disable bind how for example have then DKIM if mail is over that server?

Same for using external DNS services and disabled bind?

oh cloudpalava… good luck with that.

You have to manually create the records. I think Virtualmin can suggest some of them, which may need minor tweaks.

Thanks only aksing and no i am not using cloudflare but yes other external dns for speed and dns ddos protection

Virtualmin Pro is getting (or maybe already has, I don’t remember what version it comes in) CloudFlare DNS support as well as Google Cloud DNS, so it’ll be able to manage those DKIM records, too, at that point.

You don’t have to disable BIND. Just make sure you have the DKIM record in your DNS properly set up.

You don’t have to disable BIND. Just make sure you have the DKIM record in your DNS properly set up.

YUP that is how i use it. ( external DNS provider not cloudflare of google…)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.