Email not setup for domain

I just found out that a client isn’t getting emails. All mail stopped on the 8th of November. I searched here through the forum and found a response that said to validate the domain. I did that and I get this error:

Mail for domain : The mail server is not configured to receive email for ****

Now, I checked, and mail is setup. I restarted postfix etc, and am running updates on the server. There is one other domain that has the same error, but they use google apps for mail. The rest work fine.

I made sure that the person I am trying to send mail to exists, and that person can send without a problem.

The mails bounce back and this is what they say:

Your message could not be delivered.

The recipient’s computer rejected your e-mail.
Please verify the recipient’s e-mail address and resend.

Recipient: <*********>
Reason:    5.7.1 <********>: Relay access denied

Any help is greatly appreciated.



I had the same problem yesterday with two of my domains and I believe that the problem started after I deleted a couple of domains that had nothing to do with them, few days ago.
If someone was trying to send a message it was getting the message:

Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 5.7.1 Relay access denied (state 14).

In order to correct the problem I disabled and enabled again the mail for the domains and the problem has gone away.
The one domain that had the problem was an alias domain and the problem did not occur at the parent domain. The other one was a parent domain (without aliases). I think that the deletion of a virtual server messes up a configuration file.

That worked. I should have done that first. I just didn’t want to screw anything else up. I do believe that I did remove some domains around that time. I have done it before and never had this problem.

Oh well, fixed now.

Thanks again!