Email not going to users mailbox


My email was working fine on my server with multiple virtual domains,
except now and then I would get this error.

"refused to talk to me: 501 Syntactically invalid HELO argument(s)"

I was trying to set-up the HELO on my Postfix mail and broke something I guess as now the incoming email does not end up by the users.

The sending email does not seem to get an error so I guess its getting to the server and I can still send mail to other email addresses and that goes through.
Even if I used another email like yahoo it still does not come through.

I can log into the email accounts from Webmin so that seems to still be there, but if I send mail to my addresses and then check it tells me no new mail.

Also I noticed Virtualmin wont allow me to enable the primary email account for the users under their email & FTP setting, keeps going back to the NO selected.

Any ideas on what I have messed up?

Post edited by: southerns, at: 2008/09/16 07:58<br><br>Post edited by: southerns, at: 2008/09/16 09:01

Okay mailboxes are now showing their location on the server
and new mail does end up there
but Squirrel mail and trying to download mail still says no new mail.

Could the problem be with:

Dovecot IMAP/POP3 Server


Are you "subscribing" to the folders in question?

In Squirrelmail, click Folders, and make sure you’re subscribed to all the available folders you wish to see.

Thanx Eric for the input,

but my PC based email also does not see any new emails
and if I log into Webmin and go to the mail users I can see and open
the new mail there.

But it just wont download it. Mail client (Thunderbird)
logs on fine but says no new mail.

Some of my domains other emails have forwarders and they are also not sending the emails on.

Are you able to view the email in Usermin? You can generally access that using:

No nothing there. under inbox.

But if I log into webmin and go to users email then their is mail there for them

Hmm, where are you going in Webmin to see the users email?

I login to my Webmin.

Under Virtualmin I select the domain name that I want.

I select Edit Mail and FTP Users

on the list that shows I select the name of the user,

Under edit mail box I click - Email settings to open up is details,

I then click on the location given under - Inbox mail file

(I.E: /var/mail/

This gives me a list of emails and there are new ones there(lots of them),I can click on one and view it to.

I was wondering if its not a problem with the system not identifying the read and unread mail on the server properly,
Maybe the email client thinks its all old mail.

But then should SquirrelMail still not show them to me.

Very confusing as it seems to all be working to the point of accessing the emails, somewhere the place its putting the email and the place the system goes to retrieve them for POP/IMAP for the emails is not the same.
Well that is in my humble opinion at least how I see it.

I was just curious is it possible that I am logging into a second mail pop on my server.

I usually used ???.com (the straight domain) this is how it defaulted
is it possible that now it is meant to be mail.???.com.
Maybe my this got changed in the mess-up

If so would the user still login and just get an empty mail box if both existed.

or is it not possible,
how can I check what my mail servers address is meant to be.

It seems that its not sending email either it goes through from my mail client on my PC but nothing arrives on the other side.

I want to re-install dovecot and Postfix,

will this remove my existing users emails etc

and how do I first uninstall the old versions.

How can I redo the settings without
loosing the mail on the server

Yeah, re-installing isn’t likely to resolve the problem you’re having now, and you risk losing stuff.

My guess is a few config tweaks may get things working for you though.

I’d be willing to take a look at this if you like.

What I’d need are root login details for your server, as well as login info for a user who can send and receive email.

You can send that information to – please include a link to this forum post in the email :slight_smile:


Thanx Eric email has been sent

Hi Eric.

I seem to be getting the Shane email now

I will check out if the others are working later

So what was I missing?

Well, your Postfix config needed some work :slight_smile:

I actually started with a new one from another CentOS install.

Amongst other things though, it was missing the mailbox_command line:

mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME

The absence of the above line was why email was going to /var/mail.

I also made sure your hostname was set in there, which would resolve the HELO issues you mentioned.

Thanx Eric.

I got no Idea how a messed it up
as it had been working for about 6 months already.

Thanx Again.

Hope you had a great week-end.


Hi eric.

When I created a new Virtual server I got server creation failed:

this is what it gave said:

Failed to create virtual server : Failed to regenerate table /etc/postfix/virtual:


What is the output of:

ls -l /etc/postfix/virtual

And also this command:

postmap /etc/postfix/virtual


Thanx for the help.

Here is the first ones response:

> ls -l /etc/postfix/virtual
-rw-r–r-- 1 root root 16666 Sep 24 03:40 /etc/postfix/virtual

The second one gives no response:
(I ran it twice after the other command as you can see below)

> ls -l /etc/postfix/virtual
-rw-r–r-- 1 root root 16666 Sep 24 03:40 /etc/postfix/virtual
> postmap /etc/postfix/virtual
> postmap /etc/postfix/virtual